blob: 4cb8978e47765f53ab551c4b9130790b7609d5b8 [file] [log] [blame]
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -06001SUMMARY = "U-boot boot scripts for Raspberry Pi"
2LICENSE = "MIT"
Brad Bishopf27bdd52018-05-07 15:42:31 +02003LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05004COMPATIBLE_MACHINE = "^rpi$"
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -06005
6DEPENDS = "u-boot-mkimage-native"
7
Brad Bishop316dfdd2018-06-25 12:45:53 -04008INHIBIT_DEFAULT_DEPS = "1"
9
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010SRC_URI = "file://boot.cmd.in"
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060011
12do_compile() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013 sed -e 's/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \
14 -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/' \
15 "${WORKDIR}/boot.cmd.in" > "${WORKDIR}/boot.cmd"
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060016 mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
17}
18
Brad Bishop316dfdd2018-06-25 12:45:53 -040019inherit deploy nopackages
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060020
21do_deploy() {
22 install -d ${DEPLOYDIR}
23 install -m 0644 boot.scr ${DEPLOYDIR}
24}
25
26addtask do_deploy after do_compile before do_build
Andrew Geissler062316f2020-05-15 14:19:14 -050027
28PROVIDES += "u-boot-default-script"