Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Makes working with XML feel like you are working with JSON" |
| 2 | AUTHOR = "Martin Blech" |
| 3 | HOMEPAGE = "https://github.com/martinblech/xmltodict" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2" |
| 6 | |
| 7 | SRC_URI[md5sum] = "ddb2bd078cef4f7e3021a578034ad941" |
| 8 | SRC_URI[sha256sum] = "50d8c638ed7ecb88d90561beedbf720c9b4e851a9fa6c47ebd64e99d166d8a21" |
| 9 | |
| 10 | PYPI_PACKAGE = "xmltodict" |
| 11 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | inherit pypi setuptools3 ptest |
| 13 | |
| 14 | SRC_URI += " \ |
| 15 | file://run-ptest \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS_${PN}-ptest += " \ |
| 19 | ${PYTHON_PN}-pytest \ |
| 20 | " |
| 21 | |
| 22 | do_install_ptest() { |
| 23 | install -d ${D}${PTEST_PATH}/tests |
| 24 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 25 | } |