blob: 5cdf3164dac37d6f0da6fbb25fd1e5f04c5ee27b [file] [log] [blame]
Artem Senichev8574e7e2020-05-08 12:33:35 +03001SUMMARY = "Command-line interface"
2DESCRIPTION = "YADRO OpenBMC Command Line Interface for end users"
3HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-cli"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7# License info
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
11# Dependencies
12DEPENDS = "phosphor-user-manager"
Alexander Filippov69f2c782020-10-27 16:01:14 +030013RDEPENDS_${PN} = " \
14 ${VIRTUAL-RUNTIME_base-utils} \
15 bash \
Alexander Filippov69f2c782020-10-27 16:01:14 +030016 obmc-yadro-fwupdate \
17 obmc-yadro-lssensors \
18 obmc-yadro-netconfig \
Alexander Filippov069dc592021-07-21 11:40:06 +030019 phosphor-debug-collector-dreport \
20 phosphor-debug-collector-scripts \
Alexander Filippov69f2c782020-10-27 16:01:14 +030021 sudo \
22 systemd \
23"
24# Some platforms also require some additional packages like
25# ipmitool, obmc-yadro-lsinventory, obmc-yadro-backup ...
26# They should be appended by bbappend file in their layers
Artem Senichev8574e7e2020-05-08 12:33:35 +030027
Alexander Filippovad7324a2020-09-30 12:59:16 +030028# Directory with command handlers
29FILES_${PN} += "${datadir}/cli"
Artem Senichev8574e7e2020-05-08 12:33:35 +030030
Alexander Filippov069dc592021-07-21 11:40:06 +030031MACHINE_NAME ?= "${MACHINE}"
Artem Senichev8574e7e2020-05-08 12:33:35 +030032# Custom installation procedure
33do_install() {
34 ${B}/install.sh \
35 --dir ${D} \
Alexander Filippov069dc592021-07-21 11:40:06 +030036 --machine ${@'${MACHINE_NAME}'.split('-')[0]} \
Artem Senichev8574e7e2020-05-08 12:33:35 +030037 --admin priv-admin \
38 --operator priv-operator \
39 --user priv-user
40}
41
42# Source code repository
43S = "${WORKDIR}/git"
44SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-cli"
Alexander Filippov069dc592021-07-21 11:40:06 +030045SRCREV = "76743c3706516bae6b2bb8749706b4ea673e9358"