blob: b318c88dacf39abdef31f2254affe3d12dc8d539 [file] [log] [blame]
Adriana Kobylakb96c7502021-08-06 16:25:30 +00001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
Andrew Jeffery274f96a2020-04-03 16:20:51 +10302
Adriana Kobylakb96c7502021-08-06 16:25:30 +00003SRC_URI:remove = "file://${BPN}.conf"
Andrew Jeffery274f96a2020-04-03 16:20:51 +10304SRC_URI += "file://server.ttyVUART0.conf"
Andrew Jeffery1688b152020-02-17 15:34:34 +10305
6install_concurrent_console_config() {
7 # Install configuration for the servers and clients. Keep commandline
8 # compatibility with previous configurations by defaulting to not
9 # specifying a socket-id for VUART0/2200
10 install -m 0755 -d ${D}${sysconfdir}/${BPN}
11
12 # Remove the default client configuration as we don't to define a
13 # socket-id for the 2200 console
14 rm -f ${D}${sysconfdir}/${BPN}/client.2200.conf
15
16 # However, now link to /dev/null as a way of not specifying a
17 # socket-id while having a configuration file present. We need to
18 # provide a configuration path to meet the requirements of the packaged
19 # unit file.
20 ln -sr ${D}/dev/null ${D}${sysconfdir}/${BPN}/client.2200.conf
21
22 # We need to populate socket-id for remaining consoles
23 install -m 0644 ${WORKDIR}/client.2201.conf ${D}${sysconfdir}/${BPN}/
24
25 # Install configuration for remaining servers - the base recipe
26 # installs the configuration for the first.
27 install -m 0644 ${WORKDIR}/server.ttyVUART1.conf ${D}${sysconfdir}/${BPN}/
28}
29
Adriana Kobylakb96c7502021-08-06 16:25:30 +000030SRC_URI:append:p10bmc = " file://client.2201.conf"
31SRC_URI:append:p10bmc = " file://server.ttyVUART1.conf"
Andrew Jeffery1688b152020-02-17 15:34:34 +103032
Abhishek Patel14d29c22021-09-29 22:44:11 -050033REGISTERED_SERVICES:${PN}:append:p10bmc = " obmc_console_hypervisor:tcp:2201:"
Andrew Jeffery1688b152020-02-17 15:34:34 +103034
Adriana Kobylakb96c7502021-08-06 16:25:30 +000035SYSTEMD_SERVICE:${PN}:append:p10bmc = " obmc-console-ssh@2200.service \
Andrew Jeffery1688b152020-02-17 15:34:34 +103036 obmc-console-ssh@2201.service \
37 "
Adriana Kobylakb96c7502021-08-06 16:25:30 +000038SYSTEMD_SERVICE:${PN}:remove:p10bmc = "obmc-console-ssh.socket"
Andrew Jeffery1688b152020-02-17 15:34:34 +103039
Adriana Kobylakb96c7502021-08-06 16:25:30 +000040FILES:${PN}:remove:p10bmc = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf"
Andrew Jeffery1688b152020-02-17 15:34:34 +103041
Andrew Jeffery08413f22023-04-21 11:45:51 +093042PACKAGECONFIG:append:p10bmc = " concurrent-servers"
Andrew Jeffery1688b152020-02-17 15:34:34 +103043
Adriana Kobylakb96c7502021-08-06 16:25:30 +000044do_install:append:p10bmc() {
Andrew Jeffery1688b152020-02-17 15:34:34 +103045 install_concurrent_console_config
46}
Andrew Jeffery35c33cc2020-04-02 15:29:34 +103047
Adriana Kobylakb96c7502021-08-06 16:25:30 +000048SRC_URI:append:witherspoon-tacoma = " file://client.2201.conf"
49SRC_URI:append:witherspoon-tacoma = " file://server.ttyVUART1.conf"
Andrew Jeffery35c33cc2020-04-02 15:29:34 +103050
Abhishek Patel14d29c22021-09-29 22:44:11 -050051REGISTERED_SERVICES:${PN}:append:witherspoon-tacoma = " obmc_console_hypervisor:tcp:2201:"
Andrew Jeffery35c33cc2020-04-02 15:29:34 +103052
Adriana Kobylakb96c7502021-08-06 16:25:30 +000053SYSTEMD_SERVICE:${PN}:append:witherspoon-tacoma = " obmc-console-ssh@2200.service \
Andrew Jeffery35c33cc2020-04-02 15:29:34 +103054 obmc-console-ssh@2201.service \
55 "
Adriana Kobylakb96c7502021-08-06 16:25:30 +000056SYSTEMD_SERVICE:${PN}:remove:witherspoon-tacoma = "obmc-console-ssh.socket"
Andrew Jeffery35c33cc2020-04-02 15:29:34 +103057
Adriana Kobylakb96c7502021-08-06 16:25:30 +000058FILES:${PN}:remove:witherspoon-tacoma = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf"
Andrew Jeffery35c33cc2020-04-02 15:29:34 +103059
Adriana Kobylakb96c7502021-08-06 16:25:30 +000060EXTRA_OECONF:append:witherspoon-tacoma = " --enable-concurrent-servers"
Andrew Jeffery35c33cc2020-04-02 15:29:34 +103061
Adriana Kobylakb96c7502021-08-06 16:25:30 +000062do_install:append:witherspoon-tacoma() {
Andrew Jeffery35c33cc2020-04-02 15:29:34 +103063 install_concurrent_console_config
64}