Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2014 - 2017 Wind River Systems, Inc. |
| 3 | # |
| 4 | SUMMARY = "Base policy for CFEngine" |
| 5 | |
| 6 | DESCRIPTION = "CFEngine is an IT infrastructure automation framework \ |
| 7 | that helps engineers, system administrators and other stakeholders \ |
| 8 | in an IT system to manage and understand IT infrastructure throughout \ |
| 9 | its lifecycle. CFEngine takes systems from Build to Deploy, Manage and Audit. \ |
| 10 | \ |
| 11 | This package is intended to provide a stable base policy for \ |
| 12 | installations and upgrades, and is used by CFEngine 3.6 and newer. \ |
| 13 | \ |
| 14 | The contents of this packge are intended to live in `/var/cfengine/masterfiles` \ |
| 15 | or wherever `$(sys.masterdir)` points. \ |
| 16 | " |
| 17 | |
| 18 | HOMEPAGE = "http://cfengine.com" |
| 19 | |
| 20 | LICENSE = "MIT" |
| 21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9f76426f9ef8c6f6739fadd21d817a4f" |
| 22 | |
| 23 | SRC_URI = "https://cfengine-package-repos.s3.amazonaws.com/tarballs/${BP}.tar.gz \ |
| 24 | file://python3.patch \ |
| 25 | " |
| 26 | SRC_URI[md5sum] = "6d456fdd9bd24ff6617eeaa05efae602" |
| 27 | SRC_URI[sha256sum] = "4a071c0c4ba7df9bad93144cff5fbc0566e5172afd66201072e3193b76c55a38" |
| 28 | |
| 29 | inherit autotools |
| 30 | |
| 31 | export EXPLICIT_VERSION="${PV}" |
| 32 | |
| 33 | EXTRA_OECONF = "--prefix=${datadir}/cfengine" |
| 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 36 | rm -rf ${D}${datadir}/cfengine/modules/packages/zypper ${D}${datadir}/cfengine/modules/packages/yum |
| 37 | } |
| 38 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | FILES:${PN} = "${datadir}/cfengine" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 40 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | RDEPENDS:${PN} += "python3-core" |