Andrew Geissler | f1e4406 | 2021-04-15 15:52:46 -0500 | [diff] [blame] | 1 | SUMMARY = "Linux Kernel Runtime Guard" |
| 2 | DESCRIPTION="LKRG performs runtime integrity checking of the Linux \ |
| 3 | kernel and detection of security vulnerability exploits against the kernel." |
| 4 | SECTION = "security" |
| 5 | HOMEPAGE = "https://www.openwall.com/lkrg/" |
| 6 | LICENSE = "GPLv2" |
| 7 | |
Andrew Geissler | a1a6aef | 2021-06-25 14:23:58 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5105ead24b08a32954f34cbaa7112432" |
Andrew Geissler | f1e4406 | 2021-04-15 15:52:46 -0500 | [diff] [blame] | 9 | |
| 10 | DEPENDS = "virtual/kernel elfutils" |
| 11 | |
| 12 | SRC_URI = "https://www.openwall.com/lkrg/lkrg-${PV}.tar.gz \ |
| 13 | file://makefile_cleanup.patch " |
| 14 | |
Andrew Geissler | a1a6aef | 2021-06-25 14:23:58 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "cabbee1addbf3ae23a584203831e4bd1b730d22bfd1b3e44883214f220b3babd" |
Andrew Geissler | f1e4406 | 2021-04-15 15:52:46 -0500 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/lkrg-${PV}" |
| 18 | |
| 19 | inherit module kernel-module-split |
| 20 | |
| 21 | MAKE_TARGETS = "modules" |
| 22 | |
| 23 | MODULE_NAME = "p_lkrg" |
| 24 | |
| 25 | module_do_install() { |
| 26 | install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME} |
| 27 | install -m 0644 ${MODULE_NAME}.ko \ |
| 28 | ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko |
| 29 | } |
| 30 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | RPROVIDES:${PN} += "kernel-module-lkrg" |
Andrew Geissler | f1e4406 | 2021-04-15 15:52:46 -0500 | [diff] [blame] | 32 | |
| 33 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |