blob: 1d1a45670cf57638a67634bacdf320112e6d15e6 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require grub2.inc
2
Brad Bishop316dfdd2018-06-25 12:45:53 -04003RDEPENDS_${PN}-common += "${PN}-editenv"
4RDEPENDS_${PN} += "diffutils freetype ${PN}-common"
5
6RPROVIDES_${PN}-editenv += "${PN}-efi-editenv"
7
8PACKAGES =+ "${PN}-editenv ${PN}-common"
9FILES_${PN}-editenv = "${bindir}/grub-editenv"
10FILES_${PN}-common = " \
11 ${bindir} \
12 ${sysconfdir} \
13 ${sbindir} \
14 ${datadir}/grub \
15"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016
Brad Bishop08902b02019-08-20 09:16:51 -040017FILES_${PN}-common_append_aarch64 = " \
18 ${libdir}/${BPN} \
19"
20
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021do_install_append () {
22 install -d ${D}${sysconfdir}/grub.d
23 # Remove build host references...
24 find "${D}" -name modinfo.sh -type f -exec \
25 sed -i \
26 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
27 -e 's|${DEBUG_PREFIX_MAP}||g' \
28 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
29 {} +
30}
31
32INSANE_SKIP_${PN} = "arch"
33INSANE_SKIP_${PN}-dbg = "arch"