blob: 451db0c650c270886236daf01798c5704290ebbf [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Handle U-Boot config for a machine
2#
3# The format to specify it, in the machine, is:
4#
5# UBOOT_CONFIG ??= <default>
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006# UBOOT_CONFIG[foo] = "config,images,binary"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007#
8# or
9#
10# UBOOT_MACHINE = "config"
11#
12# Copyright 2013, 2014 (C) O.S. Systems Software LTDA.
13
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050014# Some versions of u-boot use .bin and others use .img. By default use .bin
15# but enable individual recipes to change this value.
16UBOOT_SUFFIX ??= "bin"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060017UBOOT_BINARY ?= "u-boot.${UBOOT_SUFFIX}"
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050018UBOOT_BINARYNAME ?= "${@os.path.splitext(d.getVar("UBOOT_BINARY"))[0]}"
19UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
20UBOOT_SYMLINK ?= "u-boot-${MACHINE}.${UBOOT_SUFFIX}"
21UBOOT_MAKE_TARGET ?= "all"
22
23# Output the ELF generated. Some platforms can use the ELF file and directly
24# load it (JTAG booting, QEMU) additionally the ELF can be used for debugging
25# purposes.
26UBOOT_ELF ?= ""
27UBOOT_ELF_SUFFIX ?= "elf"
28UBOOT_ELF_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_ELF_SUFFIX}"
29UBOOT_ELF_BINARY ?= "u-boot.${UBOOT_ELF_SUFFIX}"
30UBOOT_ELF_SYMLINK ?= "u-boot-${MACHINE}.${UBOOT_ELF_SUFFIX}"
31
32# Some versions of u-boot build an SPL (Second Program Loader) image that
33# should be packaged along with the u-boot binary as well as placed in the
34# deploy directory. For those versions they can set the following variables
35# to allow packaging the SPL.
36SPL_BINARY ?= ""
37SPL_BINARYNAME ?= "${@os.path.basename(d.getVar("SPL_BINARY"))}"
38SPL_IMAGE ?= "${SPL_BINARYNAME}-${MACHINE}-${PV}-${PR}"
39SPL_SYMLINK ?= "${SPL_BINARYNAME}-${MACHINE}"
40
41# Additional environment variables or a script can be installed alongside
42# u-boot to be used automatically on boot. This file, typically 'uEnv.txt'
43# or 'boot.scr', should be packaged along with u-boot as well as placed in the
44# deploy directory. Machine configurations needing one of these files should
45# include it in the SRC_URI and set the UBOOT_ENV parameter.
46UBOOT_ENV_SUFFIX ?= "txt"
47UBOOT_ENV ?= ""
48UBOOT_ENV_BINARY ?= "${UBOOT_ENV}.${UBOOT_ENV_SUFFIX}"
49UBOOT_ENV_IMAGE ?= "${UBOOT_ENV}-${MACHINE}-${PV}-${PR}.${UBOOT_ENV_SUFFIX}"
50UBOOT_ENV_SYMLINK ?= "${UBOOT_ENV}-${MACHINE}.${UBOOT_ENV_SUFFIX}"
51
52# Default name of u-boot initial env, but enable individual recipes to change
53# this value.
54UBOOT_INITIAL_ENV ?= "${PN}-initial-env"
55
56# U-Boot EXTLINUX variables. U-Boot searches for /boot/extlinux/extlinux.conf
57# to find EXTLINUX conf file.
58UBOOT_EXTLINUX_INSTALL_DIR ?= "/boot/extlinux"
59UBOOT_EXTLINUX_CONF_NAME ?= "extlinux.conf"
60UBOOT_EXTLINUX_SYMLINK ?= "${UBOOT_EXTLINUX_CONF_NAME}-${MACHINE}-${PR}"
61
62# Options for the device tree compiler passed to mkimage '-D' feature:
63UBOOT_MKIMAGE_DTCOPTS ??= ""
64SPL_MKIMAGE_DTCOPTS ??= ""
65
66# mkimage command
67UBOOT_MKIMAGE ?= "uboot-mkimage"
68UBOOT_MKIMAGE_SIGN ?= "${UBOOT_MKIMAGE}"
69
70# Arguments passed to mkimage for signing
71UBOOT_MKIMAGE_SIGN_ARGS ?= ""
72SPL_MKIMAGE_SIGN_ARGS ?= ""
Patrick Williamsc0f7c042017-02-23 20:41:17 -060073
Andrew Geissler09036742021-06-25 14:25:14 -050074# Options to deploy the u-boot device tree
75UBOOT_DTB ?= ""
76UBOOT_DTB_BINARY ??= ""
77
Patrick Williamsc124f4f2015-09-15 14:41:29 -050078python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050079 ubootmachine = d.getVar("UBOOT_MACHINE")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050080 ubootconfigflags = d.getVarFlags('UBOOT_CONFIG')
Brad Bishop6e60e8b2018-02-01 10:27:11 -050081 ubootbinary = d.getVar('UBOOT_BINARY')
82 ubootbinaries = d.getVar('UBOOT_BINARIES')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050083 # The "doc" varflag is special, we don't want to see it here
84 ubootconfigflags.pop('doc', None)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050085 ubootconfig = (d.getVar('UBOOT_CONFIG') or "").split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050086
Brad Bishopd7bf8c12018-02-25 22:55:05 -050087 if not ubootmachine and not ubootconfig:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050088 PN = d.getVar("PN")
89 FILE = os.path.basename(d.getVar("FILE"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050090 bb.debug(1, "To build %s, see %s for instructions on \
91 setting up your machine config" % (PN, FILE))
Brad Bishop316dfdd2018-06-25 12:45:53 -040092 raise bb.parse.SkipRecipe("Either UBOOT_MACHINE or UBOOT_CONFIG must be set in the %s machine configuration." % d.getVar("MACHINE"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050093
Brad Bishopd7bf8c12018-02-25 22:55:05 -050094 if ubootmachine and ubootconfig:
Brad Bishop316dfdd2018-06-25 12:45:53 -040095 raise bb.parse.SkipRecipe("You cannot use UBOOT_MACHINE and UBOOT_CONFIG at the same time.")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050096
Patrick Williamsc0f7c042017-02-23 20:41:17 -060097 if ubootconfigflags and ubootbinaries:
Brad Bishop316dfdd2018-06-25 12:45:53 -040098 raise bb.parse.SkipRecipe("You cannot use UBOOT_BINARIES as it is internal to uboot_config.bbclass.")
Patrick Williamsc0f7c042017-02-23 20:41:17 -060099
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500100 if len(ubootconfig) > 0:
101 for config in ubootconfig:
102 for f, v in ubootconfigflags.items():
103 if config == f:
104 items = v.split(',')
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600105 if items[0] and len(items) > 3:
Brad Bishop316dfdd2018-06-25 12:45:53 -0400106 raise bb.parse.SkipRecipe('Only config,images,binary can be specified!')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500107 d.appendVar('UBOOT_MACHINE', ' ' + items[0])
108 # IMAGE_FSTYPES appending
109 if len(items) > 1 and items[1]:
110 bb.debug(1, "Appending '%s' to IMAGE_FSTYPES." % items[1])
111 d.appendVar('IMAGE_FSTYPES', ' ' + items[1])
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600112 if len(items) > 2 and items[2]:
113 bb.debug(1, "Appending '%s' to UBOOT_BINARIES." % items[2])
114 d.appendVar('UBOOT_BINARIES', ' ' + items[2])
115 else:
116 bb.debug(1, "Appending '%s' to UBOOT_BINARIES." % ubootbinary)
117 d.appendVar('UBOOT_BINARIES', ' ' + ubootbinary)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500118 break
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500119}