blob: d0c9cf2a99550c51066a9d517355f71cb951f375 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
William A. Kennington IIIac69b482021-06-02 12:28:27 -070010LICENSE = "GPLv2 & LGPLv2.1+"
Andrew Geisslerc926e172021-05-07 16:11:35 -050011LIC_FILES_CHKSUM = " \
12 file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067 \
William A. Kennington IIIac69b482021-06-02 12:28:27 -070013 file://libbtrfsutil/COPYING;md5=4fbd65380cdd255951079008b364516c \
Andrew Geisslerc926e172021-05-07 16:11:35 -050014"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015SECTION = "base"
Andrew Geisslerc926e172021-05-07 16:11:35 -050016DEPENDS = "lzo util-linux zlib"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017DEPENDS_append_class-target = " udev"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
Andrew Geissler82c905d2020-04-13 13:39:40 -050019SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
20 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
Andrew Geissler09036742021-06-25 14:25:14 -050021 file://0001-btrfs-tools-include-linux-const.h-to-fix-build-with-.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 "
William A. Kennington IIIac69b482021-06-02 12:28:27 -070023SRCREV = "96d77fcefdd3b9fd297b5aabbce6dc43e2315ee2"
Andrew Geisslerc926e172021-05-07 16:11:35 -050024S = "${WORKDIR}/git"
Andrew Geissler82c905d2020-04-13 13:39:40 -050025
Andrew Geisslerc926e172021-05-07 16:11:35 -050026PACKAGECONFIG ??= " \
27 programs \
28 convert \
29 python \
30 crypto-builtin \
31"
Andrew Geissler82c905d2020-04-13 13:39:40 -050032PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
Andrew Geisslerc926e172021-05-07 16:11:35 -050033PACKAGECONFIG[programs] = "--enable-programs,--disable-programs"
34PACKAGECONFIG[convert] = "--enable-convert --with-convert=ext2,--disable-convert --without-convert,e2fsprogs"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070035PACKAGECONFIG[zoned] = "--enable-zoned,--disable-zoned"
Andrew Geissler82c905d2020-04-13 13:39:40 -050036PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native"
37PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
38
Andrew Geisslerc926e172021-05-07 16:11:35 -050039# Pick only one crypto provider
40PACKAGECONFIG[crypto-builtin] = "--with-crypto=builtin"
41PACKAGECONFIG[crypto-libgcrypt] = "--with-crypto=libgcrypt,,libgcrypt"
42PACKAGECONFIG[crypto-libsodium] = "--with-crypto=libsodium,,libsodium"
43PACKAGECONFIG[crypto-libkcapi] = "--with-crypto=libkcapi,,libkcapi"
44
Andrew Geissler82c905d2020-04-13 13:39:40 -050045inherit autotools-brokensep pkgconfig manpages
46inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'distutils3-base', '', d)}
47
48CLEANBROKEN = "1"
49
Andrew Geisslerc926e172021-05-07 16:11:35 -050050EXTRA_OECONF = "--enable-largefile"
Andrew Geissler82c905d2020-04-13 13:39:40 -050051EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
52EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
53EXTRA_PYTHON_CFLAGS_class-native = ""
54EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
55EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
56
57do_configure_prepend() {
58 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
59 mkdir -p ${S}/config
60 cp -f $(automake --print-libdir)/install-sh ${S}/config/
61}
62
Andrew Geissler82c905d2020-04-13 13:39:40 -050063
64do_install_append() {
65 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
66 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
67 fi
68}
69
Andrew Geisslerc926e172021-05-07 16:11:35 -050070RDEPENDS_${PN} = "libgcc"
71
Andrew Geissler5a43b432020-06-13 10:46:56 -050072BBCLASSEXTEND = "native nativesdk"