blob: 82a231264238f371f02db5aca5f411ad2fa274af [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Text file viewer similar to more"
2DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
3based program for viewing text files and the output from other \
4programs. Less offers many features beyond those that more does."
5HOMEPAGE = "http://www.greenwoodsoftware.com/"
6SECTION = "console/utils"
7
8# (GPLv2+ (<< 418), GPLv3+ (>= 418)) | less
9# Including email author giving permissing to use BSD
10#
11# From: Mark Nudelman <markn@greenwoodsoftware.com>
12# To: Elizabeth Flanagan <elizabeth.flanagan@intel.com
13# Date: 12/19/11
14#
15# Hi Elizabeth,
16# Using a generic BSD license for less is fine with me.
17# Thanks,
18#
19# --Mark
20#
21
22LICENSE = "GPLv3+ | BSD-2-Clause"
23LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
24 file://LICENSE;md5=ba01d0cab7f62f7f2204c7780ff6a87d \
25 "
26DEPENDS = "ncurses"
27
28SRC_URI = "http://www.greenwoodsoftware.com/${BPN}/${BPN}-${PV}.tar.gz \
29 "
30
Andrew Geissler09036742021-06-25 14:25:14 -050031SRC_URI[sha256sum] = "6aadf54be8bf57d0e2999a3c5d67b1de63808bb90deb8f77b028eafae3a08e10"
Brad Bishop19323692019-04-05 15:28:33 -040032
33UPSTREAM_CHECK_URI = "http://www.greenwoodsoftware.com/less/download.html"
34
35inherit autotools update-alternatives
36
37do_install () {
38 oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
39}
40
41ALTERNATIVE_${PN} = "less"
42ALTERNATIVE_PRIORITY = "100"