blob: 8f9c77e4fc0bf1ecaf800128e431a69907ef7d56 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Advanced tools for certain ALSA sound card drivers"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Package containing a number of tools ranging from envy24control \
3which provides complete control over all devices with an envy24 chip, to \
4firmware loaders for pcmcia, USB and the hdsp devices."
Brad Bishop19323692019-04-05 15:28:33 -04005HOMEPAGE = "http://www.alsa-project.org"
6BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
7SECTION = "console/utils"
8LICENSE = "GPLv2 & LGPLv2+"
9DEPENDS = "alsa-lib"
10
11LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
12 file://ld10k1/COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7 \
13 "
14
15SRC_URI = "https://www.alsa-project.org/files/pub/tools/${BP}.tar.bz2"
16
Andrew Geissler09036742021-06-25 14:25:14 -050017SRC_URI[sha256sum] = "35a71027a01f4d7de4722e223520e940de68b3c570b6c671691567ae28f9893e"
Brad Bishop19323692019-04-05 15:28:33 -040018
19inherit autotools-brokensep pkgconfig
20# brokensep as as10k1 (and probably more) fail out of tree
21CLEANBROKEN = "1"
22
23# Here we use PACKAGECONFIG options to pick which directories we configure/build.
24# Remember on upgrades to check that no new tools have been added.
25PACKAGECONFIG ??= "as10k1 hdajacksensetest hda-verb hdsploader ld10k1 mixartloader pcxhrloader \
26 sb16_csp seq--sbiload sscape_ctl us428control usx2yloader vxloader \
Brad Bishop19323692019-04-05 15:28:33 -040027 ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'hdajackretask', '', d)} \
28 "
29
30PACKAGECONFIG[as10k1] = ""
31PACKAGECONFIG[echomixer] = ",,gtk+"
32PACKAGECONFIG[envy24control] = ",,gtk+"
33PACKAGECONFIG[hda-verb] = ""
34PACKAGECONFIG[hdajackretask] = ",,gtk+3"
35PACKAGECONFIG[hdajacksensetest] = ",,glib-2.0"
36PACKAGECONFIG[hdspconf] = ",,fltk"
37PACKAGECONFIG[hdsploader] = ""
38PACKAGECONFIG[hdspmixer] = ",,fltk"
39PACKAGECONFIG[ld10k1] = ""
40PACKAGECONFIG[mixartloader] = ""
41PACKAGECONFIG[pcxhrloader] = ""
42PACKAGECONFIG[qlo10k1] = ",,qt-x11-free"
43PACKAGECONFIG[rmedigicontrol] = ",,gtk+"
44PACKAGECONFIG[sb16_csp] = ""
45PACKAGECONFIG[seq--sbiload] = ""
46PACKAGECONFIG[sscape_ctl] = ""
47PACKAGECONFIG[us428control] = ""
48PACKAGECONFIG[usx2yloader] = ""
49PACKAGECONFIG[vxloader] = ""
50
51# At the time of writing pyalsa is not packaged for OE, so this is not expected
52# to work.
53PACKAGECONFIG[hwmixvolume] = ",,,python-core python-pygobject pyalsa"
54
55python do_configure() {
56 for subdir in d.getVar("PACKAGECONFIG").split():
57 subdir = subdir.replace("--", "/")
58 bb.note("Configuring %s" % subdir)
59 dd = d.createCopy()
60 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
61 bb.build.exec_func("autotools_do_configure", dd)
62}
63
64python do_compile() {
65 for subdir in d.getVar("PACKAGECONFIG").split():
66 subdir = subdir.replace("--", "/")
67 bb.note("Compiling %s" % subdir)
68 dd = d.createCopy()
69 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
70 bb.build.exec_func("autotools_do_compile", dd)
71}
72
73python do_install() {
74 for subdir in d.getVar("PACKAGECONFIG").split():
75 subdir = subdir.replace("--", "/")
76 bb.note("Installing %s" % subdir)
77 dd = d.createCopy()
78 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
79 bb.build.exec_func("autotools_do_install", dd)
80
81 # Just remove bash-needing init script that isn't installed as an init script
82 try:
83 os.remove(oe.path.join(d.getVar("D"), d.getVar("sbindir"), "ld10k1d"))
84 except:
85 pass
86}
87
88FILES_${PN} += "${datadir}"