blob: 0a25d809b09b8daa3ac13641f4685928b778d8bf [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Advanced tools for certain ALSA sound card drivers"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Package containing a number of tools ranging from envy24control \
3which provides complete control over all devices with an envy24 chip, to \
4firmware loaders for pcmcia, USB and the hdsp devices."
Brad Bishop19323692019-04-05 15:28:33 -04005HOMEPAGE = "http://www.alsa-project.org"
6BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
7SECTION = "console/utils"
8LICENSE = "GPLv2 & LGPLv2+"
9DEPENDS = "alsa-lib"
10
11LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
12 file://ld10k1/COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7 \
13 "
14
15SRC_URI = "https://www.alsa-project.org/files/pub/tools/${BP}.tar.bz2"
16
Andrew Geissler4ed12e12020-06-05 18:00:41 -050017SRC_URI[md5sum] = "4e6187d2c3a8c73a9d75d66a72faed27"
18SRC_URI[sha256sum] = "bfd3c7aae1289269605d3da02279159b10e3dabdd31e658cbceaa30170957349"
Brad Bishop19323692019-04-05 15:28:33 -040019
20inherit autotools-brokensep pkgconfig
21# brokensep as as10k1 (and probably more) fail out of tree
22CLEANBROKEN = "1"
23
24# Here we use PACKAGECONFIG options to pick which directories we configure/build.
25# Remember on upgrades to check that no new tools have been added.
26PACKAGECONFIG ??= "as10k1 hdajacksensetest hda-verb hdsploader ld10k1 mixartloader pcxhrloader \
27 sb16_csp seq--sbiload sscape_ctl us428control usx2yloader vxloader \
Brad Bishop19323692019-04-05 15:28:33 -040028 ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'hdajackretask', '', d)} \
29 "
30
31PACKAGECONFIG[as10k1] = ""
32PACKAGECONFIG[echomixer] = ",,gtk+"
33PACKAGECONFIG[envy24control] = ",,gtk+"
34PACKAGECONFIG[hda-verb] = ""
35PACKAGECONFIG[hdajackretask] = ",,gtk+3"
36PACKAGECONFIG[hdajacksensetest] = ",,glib-2.0"
37PACKAGECONFIG[hdspconf] = ",,fltk"
38PACKAGECONFIG[hdsploader] = ""
39PACKAGECONFIG[hdspmixer] = ",,fltk"
40PACKAGECONFIG[ld10k1] = ""
41PACKAGECONFIG[mixartloader] = ""
42PACKAGECONFIG[pcxhrloader] = ""
43PACKAGECONFIG[qlo10k1] = ",,qt-x11-free"
44PACKAGECONFIG[rmedigicontrol] = ",,gtk+"
45PACKAGECONFIG[sb16_csp] = ""
46PACKAGECONFIG[seq--sbiload] = ""
47PACKAGECONFIG[sscape_ctl] = ""
48PACKAGECONFIG[us428control] = ""
49PACKAGECONFIG[usx2yloader] = ""
50PACKAGECONFIG[vxloader] = ""
51
52# At the time of writing pyalsa is not packaged for OE, so this is not expected
53# to work.
54PACKAGECONFIG[hwmixvolume] = ",,,python-core python-pygobject pyalsa"
55
56python do_configure() {
57 for subdir in d.getVar("PACKAGECONFIG").split():
58 subdir = subdir.replace("--", "/")
59 bb.note("Configuring %s" % subdir)
60 dd = d.createCopy()
61 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
62 bb.build.exec_func("autotools_do_configure", dd)
63}
64
65python do_compile() {
66 for subdir in d.getVar("PACKAGECONFIG").split():
67 subdir = subdir.replace("--", "/")
68 bb.note("Compiling %s" % subdir)
69 dd = d.createCopy()
70 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
71 bb.build.exec_func("autotools_do_compile", dd)
72}
73
74python do_install() {
75 for subdir in d.getVar("PACKAGECONFIG").split():
76 subdir = subdir.replace("--", "/")
77 bb.note("Installing %s" % subdir)
78 dd = d.createCopy()
79 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
80 bb.build.exec_func("autotools_do_install", dd)
81
82 # Just remove bash-needing init script that isn't installed as an init script
83 try:
84 os.remove(oe.path.join(d.getVar("D"), d.getVar("sbindir"), "ld10k1d"))
85 except:
86 pass
87}
88
89FILES_${PN} += "${datadir}"