blob: 5d0f10d0bc849b1579f3b4e2ff886c54a4ad7141 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Enchant Spell checker API Library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "A library (and command-line program) that wraps a number of \
3different spelling libraries and programs with a consistent interface."
Andrew Geissler82c905d2020-04-13 13:39:40 -05004SECTION = "libs"
5HOMEPAGE = "https://abiword.github.io/enchant/"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06006BUGTRACKER = "https://github.com/AbiWord/enchant/issues/"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007LICENSE = "LGPLv2.1+"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06008LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10DEPENDS = "glib-2.0"
11
12inherit autotools pkgconfig
13
14SRC_URI = "https://github.com/AbiWord/enchant/releases/download/v${PV}/enchant-${PV}.tar.gz"
Andrew Geissler09036742021-06-25 14:25:14 -050015SRC_URI[sha256sum] = "df68063b6c13b245fa7246b0e098a03e74f7a91c6d8947bc5c4f42ce55e2e41d"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17UPSTREAM_CHECK_URI = "https://github.com/AbiWord/enchant/releases"
18
19S = "${WORKDIR}/enchant-${PV}"
20
21EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2"
22
23PACKAGECONFIG ??= "aspell"
24PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell"
25PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell"
26
27FILES_${PN} += " \
28 ${datadir}/enchant-2 \
29 ${libdir}/enchant-2 \
30"
31FILES_${PN}-staticdev += "${libdir}/enchant-2/*.a"