blob: c9fef897891d532cb45d917b598b4e5d72a5f22f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Userspace RCU (read-copy-update) library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "A userspace RCU (read-copy-update) library. This data \
3synchronization library provides read-side access which scales linearly \
4with the number of cores. "
Andrew Geissler82c905d2020-04-13 13:39:40 -05005HOMEPAGE = "http://lttng.org/urcu"
6BUGTRACKER = "http://lttng.org/project/issues"
7
8LICENSE = "LGPLv2.1+ & MIT-style"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=e548d28737289d75a8f1e01ba2fd7825 \
10 file://include/urcu/urcu.h;beginline=4;endline=32;md5=4de0d68d3a997643715036d2209ae1d9 \
11 file://include/urcu/uatomic/x86.h;beginline=4;endline=21;md5=58e50bbd8a2f073bb5500e6554af0d0b"
12
13SRC_URI = "http://lttng.org/files/urcu/userspace-rcu-${PV}.tar.bz2"
14
Andrew Geissler09036742021-06-25 14:25:14 -050015SRC_URI[md5sum] = "8cb75dbb05774c03e66c63cb3186dd59"
16SRC_URI[sha256sum] = "cbb20dbe1a892c2a4d8898bac4316176e585392693d498766ccbbc68cf20ba20"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18S = "${WORKDIR}/userspace-rcu-${PV}"
19inherit autotools multilib_header
20
21CPPFLAGS_append_riscv64 = " -pthread -D_REENTRANT"
22
23do_install_append() {
24 oe_multilib_header urcu/config.h
25}