blob: 552a44583cd7200c9b3cc3cf17670b5c75ea258a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
Andrew Geissler09209ee2020-12-13 08:44:15 -060018GIR_MESON_ENABLE_FLAG = "enabled"
19GIR_MESON_DISABLE_FLAG = "disabled"
20
21SRC_URI += " file://0001-tests-test-font.c-drop-assert-that-fails-with-Cantar.patch"
22SRC_URI[archive.sha256sum] = "391f26f3341c2d7053e0fb26a956bd42360dadd825efe7088b1e9340a65e74e6"
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
24DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
27 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
28
29PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
30PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
31PACKAGECONFIG[thai] = ",,libthai"
32
33GTKDOC_MESON_OPTION = "gtk_doc"
34GIR_MESON_OPTION = 'introspection'
35
Andrew Geissler09209ee2020-12-13 08:44:15 -060036do_configure_prepend() {
37 chmod +x ${S}/tests/*.py
38}
39
Andrew Geissler82c905d2020-04-13 13:39:40 -050040do_configure_prepend_toolchain-clang() {
41 sed -i -e "/Werror=implicit-fallthrough/d" ${S}/meson.build
42}
43
44LEAD_SONAME = "libpango-1.0*"
45
46FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
47
48RDEPENDS_${PN}-ptest += "cantarell-fonts"
49RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
50
51RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
52 pango-module-basic-fc pango-module-arabic-lang"
53
54BBCLASSEXTEND = "native nativesdk"