blob: 498275ee80c9497f87f13441d74a530352c2fbbd [file] [log] [blame]
Tim Lee1c9c10a2022-07-05 17:14:18 +08001SUMMARY = "Image Generation and Programming Scripts for NPCM8XX (Arbel) devices"
2DESCRIPTION = "Image Generation and Programming Scripts for NPCM8XX (Arbel) devices"
3HOMEPAGE = "https://github.com/Nuvoton-Israel/igps-npcm8xx"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = " \
8 git://github.com/Nuvoton-Israel/igps-npcm8xx;branch=main;protocol=https \
9 file://0001-Adjust-paths-for-use-with-Bitbake.patch \
10"
11
Tim Lee09508aa2022-09-13 15:40:47 +080012# tag IGPS_03.06.04
13SRCREV = "6b056bb97a8f0e677d196afb6704372cae8bdd5b"
Tim Lee1c9c10a2022-07-05 17:14:18 +080014
15S = "${WORKDIR}/git"
16
17DEST = "${D}${datadir}/${BPN}"
18
Tim Lee1c9c10a2022-07-05 17:14:18 +080019do_install() {
20 install -d ${DEST}
21 install py_scripts/ImageGeneration/references/BootBlockAndHeader_${DEVICE_GEN}_${IGPS_MACHINE}.xml ${DEST}
22 install py_scripts/ImageGeneration/references/UbootHeader_${DEVICE_GEN}.xml ${DEST}
23 install py_scripts/ImageGeneration/inputs/BL31_AndHeader.xml ${DEST}
24 install py_scripts/ImageGeneration/inputs/OpTeeAndHeader.xml ${DEST}
25}
26
27inherit native