blob: 4ede3c8c6b69a735866d6dac0e16362c1cd06451 [file] [log] [blame]
Brad Bishop0a921262019-09-24 07:40:45 -04001DESCRIPTION = "Utilities to collect and visualise system statistics"
2HOMEPAGE = "http://www.i-scream.org/libstatgrab/"
3
4LICENSE = "GPL-2.0+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "ncurses"
8
9PACKAGES_prepend = "statgrab statgrab-dbg saidar saidar-dbg ${PN}-mrtg "
10
11# don't use the git tag unless docbooc2x is available to build the manpages
12SRC_URI = "https://github.com/libstatgrab/libstatgrab/releases/download/LIBSTATGRAB_0_92/libstatgrab-0.92.tar.gz \
13 "
14SRC_URI[md5sum] = "5362b2ddbec54b3901e7d70c22cda249"
15SRC_URI[sha256sum] = "5bf1906aff9ffc3eeacf32567270f4d819055d8386d98b9c8c05519012d5a196"
16
17# Perl5 is for tests only
18EXTRA_OECONF = "--without-perl5 --with-mnttab=/proc/mounts"
19
20inherit autotools pkgconfig
21
22FILES_statgrab = "${bindir}/statgrab"
23FILES_statgrab-dbg = "${bindir}/.debug/statgrab"
24FILES_saidar = "${bindir}/saidar"
25FILES_saidar-dbg = "${bindir}/.debug/saidar"
26FILES_${PN}-mrtg = "${bindir}/statgrab-make-mrtg-config ${bindir}/statgrab-make-mrtg-index"
27RDEPENDS_${PN}-mrtg_append = "perl statgrab"