blob: 54606e8b645580d9fbee04641f0184a361e8caa3 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "sends ICMP ECHO_REQUEST packets to network hosts"
2DESCRIPTION = "fping is a ping like program which uses the Internet Control \
3Message Protocol (ICMP) echo request to determine if a target host is \
4responding. fping differs from ping in that you can specify any number of \
5targets on the command line, or specify a file containing the lists of \
6targets to ping. Instead of sending to one target until it times out or \
7replies, fping will send out a ping packet and move on to the next target \
8in a round-robin fashion."
9HOMEPAGE = "http://www.fping.org/"
10SECTION = "net"
11LICENSE = "BSD"
Brad Bishop34ae6002019-04-08 15:21:03 -040012LIC_FILES_CHKSUM = "file://COPYING;md5=c6170fbadddfcd74f011515291d96901"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050013
14SRC_URI = "http://www.fping.org/dist/fping-${PV}.tar.gz"
Andrew Geisslerd688a012020-09-18 13:36:00 -050015SRC_URI[sha256sum] = "ed38c0b9b64686a05d1b3bc1d66066114a492e04e44eef1821d43b1263cd57b8"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016
17S = "${WORKDIR}/fping-${PV}"
18
19inherit autotools
20
21EXTRA_OECONF = "--enable-ipv4"
22
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"