blob: c2ec856fdbf4e500cbc9af882a824a8c10b0561a [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
2HOMEPAGE = "https://github.com/idan/oauthlib"
3
Brad Bishop2d39a062019-10-28 08:33:36 -04004LICENSE = "BSD-3-Clause"
Andrew Geissler89770b02020-06-13 10:40:47 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=abd2675e944a2011aed7e505290ba482"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006
Andrew Geissler69721092021-07-23 12:57:00 -04007SRC_URI[sha256sum] = "8f0215fcc533dd8dd1bee6f4c412d4f0cd7297307d43ac61666389e3bc3198a3"
Brad Bishop316dfdd2018-06-25 12:45:53 -04008
Andrew Geissler89770b02020-06-13 10:40:47 -05009inherit pypi setuptools3
Brad Bishop316dfdd2018-06-25 12:45:53 -040010
11# The following configs & dependencies are from setuptools extras_require.
12# These dependencies are optional, hence can be controlled via PACKAGECONFIG.
13# The upstream names may not correspond exactly to bitbake package names.
14#
15# Uncomment this line to enable all the optional features.
16#PACKAGECONFIG ?= "test signedtoken signals rsa"
17PACKAGECONFIG[test] = ",,,${PYTHON_PN}-blinker ${PYTHON_PN}-cryptography ${PYTHON_PN}-nose ${PYTHON_PN}-pyjwt"
18PACKAGECONFIG[signedtoken] = ",,,${PYTHON_PN}-cryptography ${PYTHON_PN}-pyjwt"
19PACKAGECONFIG[signals] = ",,,${PYTHON_PN}-blinker"
20PACKAGECONFIG[rsa] = ",,,${PYTHON_PN}-cryptography"
21
Patrick Williams213cb262021-08-07 19:21:33 -050022RDEPENDS:${PN} += "${PYTHON_PN}-core ${PYTHON_PN}-crypt ${PYTHON_PN}-datetime ${PYTHON_PN}-json ${PYTHON_PN}-logging ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-unittest"