blob: 323fe18fd1e489e32a515fa0ec4b5cbf2491e2d9 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A MutableSet that remembers its order, so that every entry has an index."
2HOMEPAGE = "http://github.com/LuminosoInsight/ordered-set"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=2b36be0d99854aa2ae292a800a7c1d4e"
5
Andrew Geisslerc87764f2020-06-27 00:16:32 -05006SRC_URI[md5sum] = "5d88f3870c32d4868b28c8fe833f7e74"
7SRC_URI[sha256sum] = "ba93b2df055bca202116ec44b9bead3df33ea63a7d5827ff8e16738b97f33a95"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
Andrew Geissler82c905d2020-04-13 13:39:40 -05009inherit pypi setuptools3 ptest
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010
11DEPENDS += "python3-pytest-runner-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13SRC_URI += " \
14 file://run-ptest \
15"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050018 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 cp -f ${S}/test.py ${D}${PTEST_PATH}/
23}