blob: d572cab17de7501d17f181945cce822e2588ef60 [file] [log] [blame]
Andrew Geissler3e34fba2021-03-05 15:21:55 -06001SUMMARY = "CircuitPython helper library provides higher level objects to control motors and servos."
2HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_Motor"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b72678307cc7c10910b5ef460216af07"
5
Andrew Geissler595f6302022-01-24 19:11:47 +00006SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_Motor.git;branch=main;protocol=https"
Andrew Geissler3e34fba2021-03-05 15:21:55 -06007SRCREV = "2251bfc0501d0acfb96c0a43f4f2b4c6a10ca14e"
8
9S = "${WORKDIR}/git"
10
11inherit setuptools3
12
13DEPENDS += "python3-setuptools-scm-native"
14
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN} += " \
Andrew Geissler3e34fba2021-03-05 15:21:55 -060016 python3-adafruit-blinka \
17 python3-core \
18"