blob: 8158eeaf4ca132fe7da8e16770dce992b93673fc [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001do_rootfs[depends] += "prelink-native:do_populate_sysroot"
2
Patrick Williams213cb262021-08-07 19:21:33 -05003IMAGE_PREPROCESS_COMMAND:append:libc-glibc = " prelink_setup; prelink_image; "
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05004
5python prelink_setup () {
6 oe.utils.write_ld_so_conf(d)
7}
8
9inherit linuxloader
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010
11prelink_image () {
12# export PSEUDO_DEBUG=4
13# /bin/env | /bin/grep PSEUDO
14# echo "LD_LIBRARY_PATH=$LD_LIBRARY_PATH"
15# echo "LD_PRELOAD=$LD_PRELOAD"
16
17 pre_prelink_size=`du -ks ${IMAGE_ROOTFS} | awk '{size = $1 ; print size }'`
18 echo "Size before prelinking $pre_prelink_size."
19
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 # The filesystem may not contain sysconfdir so establish what is present
21 # to enable cleanup after temporary creation of sysconfdir if needed
22 presentdir="${IMAGE_ROOTFS}${sysconfdir}"
23 while [ "${IMAGE_ROOTFS}" != "${presentdir}" ] ; do
24 [ ! -d "${presentdir}" ] || break
25 presentdir=`dirname "${presentdir}"`
26 done
27
28 mkdir -p "${IMAGE_ROOTFS}${sysconfdir}"
29
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030 # We need a prelink conf on the filesystem, add one if it's missing
31 if [ ! -e ${IMAGE_ROOTFS}${sysconfdir}/prelink.conf ]; then
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050032 cp ${STAGING_ETCDIR_NATIVE}/prelink.conf \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033 ${IMAGE_ROOTFS}${sysconfdir}/prelink.conf
34 dummy_prelink_conf=true;
35 else
36 dummy_prelink_conf=false;
37 fi
38
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050039 # We need a ld.so.conf with pathnames in,prelink conf on the filesystem, add one if it's missing
40 ldsoconf=${IMAGE_ROOTFS}${sysconfdir}/ld.so.conf
41 if [ -e $ldsoconf ]; then
42 cp $ldsoconf $ldsoconf.prelink
43 fi
44 cat ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf >> $ldsoconf
45
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080046 dynamic_loader=${@get_linuxloader(d)}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050047
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048 # prelink!
Andrew Geisslereff27472021-10-29 15:35:00 -050049 if [ "$REPRODUCIBLE_TIMESTAMP_ROOTFS" = "" ]; then
50 export PRELINK_TIMESTAMP=`git log -1 --pretty=%ct `
Brad Bishopd7bf8c12018-02-25 22:55:05 -050051 else
Andrew Geisslereff27472021-10-29 15:35:00 -050052 export PRELINK_TIMESTAMP=$REPRODUCIBLE_TIMESTAMP_ROOTFS
Brad Bishopd7bf8c12018-02-25 22:55:05 -050053 fi
Andrew Geisslereff27472021-10-29 15:35:00 -050054 ${STAGING_SBINDIR_NATIVE}/prelink --root ${IMAGE_ROOTFS} -am -N -c ${sysconfdir}/prelink.conf --dynamic-linker $dynamic_loader
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055
56 # Remove the prelink.conf if we had to add it.
57 if [ "$dummy_prelink_conf" = "true" ]; then
58 rm -f ${IMAGE_ROOTFS}${sysconfdir}/prelink.conf
59 fi
60
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050061 if [ -e $ldsoconf.prelink ]; then
62 mv $ldsoconf.prelink $ldsoconf
63 else
64 rm $ldsoconf
65 fi
66
Andrew Geissler82c905d2020-04-13 13:39:40 -050067 # Remove any directories temporarily created for sysconfdir
68 cleanupdir="${IMAGE_ROOTFS}${sysconfdir}"
69 while [ "${presentdir}" != "${cleanupdir}" ] ; do
70 rmdir "${cleanupdir}"
71 cleanupdir=`dirname ${cleanupdir}`
72 done
73
Patrick Williamsc124f4f2015-09-15 14:41:29 -050074 pre_prelink_size=`du -ks ${IMAGE_ROOTFS} | awk '{size = $1 ; print size }'`
75 echo "Size after prelinking $pre_prelink_size."
76}