blob: 46952e46851f1e98100ca3f3cc61e7580e556533 [file] [log] [blame]
Andrew Geissler4ed12e12020-06-05 18:00:41 -05001SUMMARY = "helper tools for all init systems"
2DESCRIPTION = "This package contains helper tools that are necessary for switching between \
3the various init systems that Debian contains (e. g. sysvinit or \
4systemd). An example is deb-systemd-helper, a script that enables systemd unit \
5files without depending on a running systemd. \
6\
7It also includes the \"service\", \"invoke-rc.d\", and \"update-rc.d\" scripts which \
8provide an abstraction for enabling, disabling, starting, and stopping \
9services for all supported Debian init systems as specified by the policy. \
10\
11While this package is maintained by pkg-systemd-maintainers, it is NOT \
12specific to systemd at all. Maintainers of other init systems are welcome to \
13include their helpers in this package."
14HOMEPAGE = "https://salsa.debian.org/debian/init-system-helpers"
15SECTION = "base"
16LICENSE = "BSD-3-Clause & GPLv2"
17LIC_FILES_CHKSUM = "file://debian/copyright;md5=ee2b1830fcfead84d07bc060ec43e072"
18
Andrew Geisslerd1e89492021-02-12 15:35:20 -060019SRCREV = "dbd9197569c0935029acd5c9b02b84c68fd937ee"
Andrew Geissler595f6302022-01-24 19:11:47 +000020SRC_URI = "git://salsa.debian.org/debian/init-system-helpers.git;protocol=https;branch=master"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050021
22S = "${WORKDIR}/git"
23
24do_configure[noexec] = "1"
25do_compile[noexec] = "1"
26
27do_install() {
28 install -d -m 0755 ${D}${sbindir}
29 install -m 0755 ${S}/script/invoke-rc.d ${D}${sbindir}
30 install -m 0755 ${S}/script/service ${D}${sbindir}
31}
32
33PACKAGES += "${PN}-invoke-rc.d ${PN}-service"
34
Patrick Williams213cb262021-08-07 19:21:33 -050035FILES:${PN} = ""
36FILES:${PN}-invoke-rc.d = "${sbindir}/invoke-rc.d"
37FILES:${PN}-service = "${sbindir}/service"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050038
Patrick Williams213cb262021-08-07 19:21:33 -050039ALLOW_EMPTY:${PN} = "1"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050040
Patrick Williams213cb262021-08-07 19:21:33 -050041RRECOMMENDS:${PN} += "${PN}-invoke-rc.d ${PN}-service"