blob: c66ff3a7da9221e41cdc5783c5bc6a9628d31a58 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
2DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
3bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
4and copying files using the block map. The idea is that large file containing \
5unused blocks, like raw system image files, can be copied or flashed a lot \
6faster with bmaptool than with traditional tools like "dd" or "cp"."
7HOMEPAGE = "https://github.com/01org/bmap-tools"
8SECTION = "console/utils"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
Andrew Geissler595f6302022-01-24 19:11:47 +000012SRC_URI = "git://github.com/intel/${BPN};branch=master;protocol=https"
Brad Bishop19323692019-04-05 15:28:33 -040013
Andrew Geissler95ac1b82021-03-31 14:34:31 -050014SRCREV = "c0673962a8ec1624b5189dc1d24f33fe4f06785a"
Brad Bishop19323692019-04-05 15:28:33 -040015S = "${WORKDIR}/git"
16PV .= "+git${SRCPV}"
17
18UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
19
Andrew Geissler95ac1b82021-03-31 14:34:31 -050020# Need df from coreutils
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN} = "python3-core python3-compression python3-mmap python3-setuptools python3-fcntl python3-six coreutils"
Brad Bishop19323692019-04-05 15:28:33 -040022
23inherit python3native
24inherit setuptools3
25
Andrew Geissler5a43b432020-06-13 10:46:56 -050026BBCLASSEXTEND = "native nativesdk"