blob: 1da87110e7b8bc62e974a2539aa4705f54ac75cc [file] [log] [blame]
Adriana Kobylakb96c7502021-08-06 16:25:30 +00001OBMC_IMAGE_EXTRA_INSTALL:append:ibm-ac-server = " mboxd max31785-msl phosphor-msl-verify liberation-fonts uart-render-controller first-boot-set-hostname"
Andrew Geissler0c3e5ee2021-12-17 19:30:02 +00002OBMC_IMAGE_EXTRA_INSTALL:append:p10bmc = " mboxd"
Adriana Kobylakb96c7502021-08-06 16:25:30 +00003OBMC_IMAGE_EXTRA_INSTALL:append:mihawk = " mboxd liberation-fonts uart-render-controller "
Andrew Geisslerd1b5b202021-01-04 12:16:39 -06004
5# remove so things fit in available flash space
Adriana Kobylakb96c7502021-08-06 16:25:30 +00006IMAGE_FEATURES:remove:witherspoon = "obmc-user-mgmt-ldap"
Andrew Geissler3475f832021-08-12 09:09:41 -04007IMAGE_FEATURES:remove:witherspoon = "obmc-telemetry"
Joseph Reynolds68e567f2021-02-24 17:20:01 -06008
Andrew Geissler0f80cda2021-08-31 15:50:20 -05009# Generic IPMI FRU vpd collection not needed on p10bmc
10IMAGE_FEATURES:remove:p10bmc = "obmc-fru-ipmi"
11
Joseph Reynolds68e567f2021-02-24 17:20:01 -060012# Optionally configure IBM service accounts
13#
14# To configure your distro, add the following line to its config:
15# DISTRO_FEATURES += "ibm-service-account-policy"
16#
17# The service account policy is as follows:
18# root - The root account remains present. It is needed for internal
19# accounting purposes and for debugging service access.
20# admin - Provides administrative control over the BMC. The role is
21# SystemAdministrator. Admin users have access to interfaces including:
22# Redfish, REST APIs, Web. No access to the BMC via: the BMC's physical
23# console, SSH to the BMC's command line.
24# IPMI access is not granted by default, but admins can authorize
25# themselves and enable the IPMI service.
26# The admin has access to the host console: ssh -p2200 admin@${bmc}.
27# The admin account does not have a home directory.
28# service - Provides IBM service and support representatives (SSRs, formerly
29# known as customer engineers or CEs) access to the BMC. The role is
30# OemIBMServiceAgent. The service user has full admin access, plus access
31# to BMC interfaces intended only to service the BMC and host, including
32# SSH access to the BMC's command line.
33# The service account is not authorized to IPMI because of the inherent
34# security weakness in the IPMI spec and also because the IPMI
35# implementation was not enhanced to use the ACF support.
36# The service account does not have a home directory. The home directory is
37# set to / (the root directory) to allow dropbear ssh connections.
38
Joseph Reynolds516363e2021-08-04 10:01:42 -050039# Override defaults from meta-phosphor/conf/distro/include/phosphor-defaults.inc
Joseph Reynolds68e567f2021-02-24 17:20:01 -060040inherit extrausers
41
Joseph Reynolds68e567f2021-02-24 17:20:01 -060042#IBM_EXTRA_USERS_PARAMS += " \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050043# usermod -p ${DEFAULT_OPENBMC_PASSWORD} root; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060044# "
45
46# Add group "wheel" (before adding the "service" account).
47IBM_EXTRA_USERS_PARAMS += " \
48 groupadd wheel; \
49 "
50
51# Add the "admin" account.
52IBM_EXTRA_USERS_PARAMS += " \
53 useradd -M -d / --groups priv-admin,redfish,web -s /sbin/nologin admin; \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050054 usermod -p ${DEFAULT_OPENBMC_PASSWORD} admin; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060055 "
56
57# Add the "service" account.
58IBM_EXTRA_USERS_PARAMS += " \
59 useradd -M -d / --groups priv-admin,redfish,web,wheel service; \
Joseph Reynolds356f9e12021-07-23 20:15:32 -050060 usermod -p ${DEFAULT_OPENBMC_PASSWORD} service; \
Joseph Reynolds68e567f2021-02-24 17:20:01 -060061 "
62
63# This is recipe specific to ensure it takes effect.
Adriana Kobylakb96c7502021-08-06 16:25:30 +000064EXTRA_USERS_PARAMS:pn-obmc-phosphor-image += "${@bb.utils.contains('DISTRO_FEATURES', 'ibm-service-account-policy', "${IBM_EXTRA_USERS_PARAMS}", '', d)}"
Joseph Reynolds68e567f2021-02-24 17:20:01 -060065
66# The service account needs sudo.
Adriana Kobylakb96c7502021-08-06 16:25:30 +000067IMAGE_INSTALL:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ibm-service-account-policy', 'sudo', '', d)}"