blob: b5d53bb112e175abe6ccbb483384435b3ffc5484 [file] [log] [blame]
Patrick Williams213cb262021-08-07 19:21:33 -05001# Copyright (C) 2021 Mingli Yu <mingli.yu@windriver.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "General-purpose scalable concurrent malloc implementation"
5
6DESCRIPTION = "jemalloc is a general purpose malloc(3) implementation that emphasizes \
7fragmentation avoidance and scalable concurrency support."
8
9HOMEPAGE = "https://github.com/jemalloc/jemalloc"
10LICENSE = "BSD"
11
12SECTION = "libs"
13
14LIC_FILES_CHKSUM = "file://README;md5=6900e4a158982e4c4715bf16aa54fa10"
15
Patrick Williams0ca19cc2021-08-16 14:03:13 -050016SRC_URI = "git://github.com/jemalloc/jemalloc.git \
17 file://0001-Makefile.in-make-sure-doc-generated-before-install.patch \
18 file://run-ptest \
19"
Patrick Williams213cb262021-08-07 19:21:33 -050020
21SRCREV = "ea6b3e973b477b8061e0076bb257dbd7f3faa756"
22
23S = "${WORKDIR}/git"
24
Patrick Williams0ca19cc2021-08-16 14:03:13 -050025inherit autotools ptest
Patrick Williams213cb262021-08-07 19:21:33 -050026
27EXTRA_AUTORECONF += "--exclude=autoheader"
28
29EXTRA_OECONF:append:libc-musl = " --with-jemalloc-prefix=je_"
Patrick Williams0ca19cc2021-08-16 14:03:13 -050030
31do_compile_ptest() {
32 oe_runmake tests
33}
34
35do_install_ptest() {
36 install -d ${D}${PTEST_PATH}/tests
37 subdirs="test/unit test/integration test/stress "
38 for tooltest in ${subdirs}
39 do
40 cp -r ${B}/${tooltest} ${D}${PTEST_PATH}/tests
41 done
42 find ${D}${PTEST_PATH}/tests \( -name "*.d" -o -name "*.o" \) -exec rm -f {} \;
43}