blob: 9c5e75505049f7699eb6d31b202c502d7b7eb95d [file] [log] [blame]
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +05301SUMMARY = "Phosphor Physical LED Controller daemon"
2DESCRIPTION = "Daemon to trigger actions on a physical LED"
3HOMEPAGE = "http://github.com/openbmc/phosphor-led-sysfs"
4PR = "r1"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8inherit autotools pkgconfig
Brad Bishop807fdd22017-01-26 12:36:52 -05009inherit obmc-phosphor-dbus-service
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +053010
11DEPENDS += "autoconf-archive-native"
12DEPENDS += "sdbusplus"
Xo Wang0d7ad402017-03-14 16:40:31 -070013DEPENDS += "phosphor-dbus-interfaces"
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +053014RDEPENDS_${PN} += "libsystemd"
15
Brad Bishop807fdd22017-01-26 12:36:52 -050016DBUS_SERVICE_${PN} += "xyz.openbmc_project.led.controller@.service"
17
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +053018SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs"
Brad Bishop807fdd22017-01-26 12:36:52 -050019SRC_URI += "file://70-leds.rules"
Patrick Williamse8a5ade2017-03-13 16:40:06 -050020SRCREV = "e089173fac7240173b227ac61d32fdf2ef367a83"
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +053021S = "${WORKDIR}/git"
Brad Bishop807fdd22017-01-26 12:36:52 -050022
23do_install_append() {
24 install -d ${D}/${base_libdir}/udev/rules.d/
25 install ${WORKDIR}/70-leds.rules ${D}/${base_libdir}/udev/rules.d/
26}