blob: cb845c307040b091a7ef061878660fc74a780a6e [file] [log] [blame]
Brad Bishopd5ae7d92018-06-14 09:52:03 -07001SUMMARY = "GNU cpio is a program to manage archives of files"
2DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \
3another. It handles a number of cpio formats as well as reading and writing tar files."
4HOMEPAGE = "http://www.gnu.org/software/cpio/"
5SECTION = "base"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
8
9SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
10 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
11 file://0001-Fix-CVE-2015-1197.patch \
Brad Bishopd5ae7d92018-06-14 09:52:03 -070012 file://0001-CVE-2016-2037-1-byte-out-of-bounds-write.patch \
Brad Bishopa5c52ff2018-11-23 10:55:50 +130013 file://0001-Fix-segfault-with-append.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050014 "
15
16SRC_URI[md5sum] = "fc207561a86b63862eea4b8300313e86"
17SRC_URI[sha256sum] = "08a35e92deb3c85d269a0059a27d4140a9667a6369459299d08c17f713a92e73"
Brad Bishopd5ae7d92018-06-14 09:52:03 -070018
19inherit autotools gettext texinfo
20
21EXTRA_OECONF += "DEFAULT_RMT_DIR=${base_sbindir}"
22
23do_install () {
24 autotools_do_install
25 if [ "${base_bindir}" != "${bindir}" ]; then
26 install -d ${D}${base_bindir}/
27 mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio"
28 rmdir ${D}${bindir}/
29 fi
Brad Bishop19323692019-04-05 15:28:33 -040030
31 # Avoid conflicts with the version from tar
32 mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8"
Brad Bishopd5ae7d92018-06-14 09:52:03 -070033}
34
35PACKAGES =+ "${PN}-rmt"
36
37FILES_${PN}-rmt = "${base_sbindir}/rmt*"
38
39inherit update-alternatives
40
41ALTERNATIVE_PRIORITY = "100"
42
43ALTERNATIVE_${PN} = "cpio"
44ALTERNATIVE_${PN}-rmt = "rmt"
45
46ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
47
48ALTERNATIVE_PRIORITY[rmt] = "50"
49ALTERNATIVE_LINK_NAME[rmt] = "${base_sbindir}/rmt"
50
51BBCLASSEXTEND = "native"