Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Install a Debian system into a subdirectory" |
| 2 | HOMEPAGE = "https://wiki.debian.org/Debootstrap" |
| 3 | SECTION = "devel" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608" |
| 6 | |
| 7 | SRC_URI = "\ |
| 8 | http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_${PV}.tar.gz \ |
| 9 | file://0001-support-to-override-usr-sbin-and-usr-share.patch \ |
| 10 | file://0002-support-to-override-usr-bin-arch-test.patch \ |
| 11 | file://0001-do-not-hardcode-the-full-path-of-dpkg.patch \ |
| 12 | " |
| 13 | |
Patrick Williams | 975a06f | 2022-10-21 14:42:47 -0500 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "09e7f8795fee894b77994213ee3a588e9d8f96ddf5f93afdec91e9a137aa7866" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/debootstrap" |
| 17 | |
| 18 | DEPENDS = " \ |
| 19 | virtual/fakeroot-native \ |
| 20 | " |
| 21 | |
| 22 | fakeroot do_install() { |
| 23 | oe_runmake 'DESTDIR=${D}' install |
| 24 | chown -R root:root ${D}${datadir}/debootstrap |
| 25 | } |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |