blob: 72249ff1eafe5b4bd18fd0b45a2da0ee555b8390 [file] [log] [blame]
Brad Bishop65b40a82016-06-09 22:22:46 -04001# In general this class should only be used by board layers
2# that keep their machine-readable-workbook in the skeleton repository.
3
4inherit allarch
5inherit setuptools
Brad Bishop382cb1b2016-06-15 22:01:33 -04006inherit pythonnative
Brad Bishop65b40a82016-06-09 22:22:46 -04007
Brad Bishop382cb1b2016-06-15 22:01:33 -04008DEPENDS += "python"
Brad Bishop65b40a82016-06-09 22:22:46 -04009SRC_URI += "git://github.com/openbmc/skeleton;subpath=configs"
10S = "${WORKDIR}/configs"
11
12python() {
13 machine = d.getVar('MACHINE', True).capitalize() + '.py'
14 d.setVar('_config_in_skeleton', machine)
15}
16
17do_make_setup() {
18 cp ${S}/${_config_in_skeleton} \
19 ${S}/obmc_system_config.py
20 cat <<EOF > ${S}/setup.py
21from distutils.core import setup
22
23setup(name='${BPN}',
24 version='${PR}',
25 py_modules=['obmc_system_config'],
26 )
27EOF
28}
29
30addtask make_setup after do_patch before do_configure