blob: 1559bfd3f9b18a00843438d4da489ccd13fc50d7 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "The NTFS-3G driver is an open source, freely available NTFS driver for Linux with read and write support."
2HOMEPAGE = "http://www.ntfs-3g.org/"
3DEPENDS = "fuse libgcrypt"
4PROVIDES = "ntfsprogs ntfs-3g"
5LICENSE = "GPLv2 & LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
8
9SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz \
10 file://0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch \
Brad Bishop0f291cc2019-09-01 15:16:57 -040011 ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','file://0001-Make-build-support-usrmerge.patch','',d)} \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012"
13S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}"
14SRC_URI[md5sum] = "d97474ae1954f772c6d2fa386a6f462c"
15SRC_URI[sha256sum] = "3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5"
16
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017UPSTREAM_CHECK_URI = "https://www.tuxera.com/community/open-source-ntfs-3g/"
18UPSTREAM_CHECK_REGEX = "ntfs-3g_ntfsprogs-(?P<pver>\d+(\.\d+)+)\.tgz"
19
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020inherit autotools pkgconfig
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[uuid] = "--with-uuid,--without-uuid,util-linux"
24
25# required or it calls ldconfig at install step
26EXTRA_OEMAKE = "LDCONFIG=echo"
27
28PACKAGES =+ "ntfs-3g ntfsprogs libntfs-3g"
29
30FILES_ntfs-3g = "${base_sbindir}/*.ntfs-3g ${bindir}/ntfs-3g* ${base_sbindir}/mount.ntfs"
31RDEPENDS_ntfs-3g += "fuse"
32RRECOMMENDS_ntfs-3g = "util-linux-mount"
33
34FILES_ntfsprogs = "${base_sbindir}/* ${bindir}/* ${sbindir}/*"
35FILES_libntfs-3g = "${libdir}/*${SOLIBS}"
36
37do_install_append() {
38 # Standard mount will execute the program /sbin/mount.TYPE
39 # when called. Add the symbolic to let mount could find ntfs.
40 ln -sf mount.ntfs-3g ${D}/${base_sbindir}/mount.ntfs
41 rmdir ${D}${libdir}/ntfs-3g
42}
43
44# Satisfy the -dev runtime dependency
45ALLOW_EMPTY_${PN} = "1"