blob: 98e8050b814c085f6d765489a423e57b4f73d9ff [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Netfilter Tables userspace utillites"
2SECTION = "net"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d1a78fdd879a263a5e0b42d1fc565e79"
5
6DEPENDS = "libmnl libnftnl readline gmp bison-native"
7
8UPSTREAM_CHECK_URI = "https://www.netfilter.org/projects/nftables/files/"
9
10SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2"
Brad Bishop0f291cc2019-09-01 15:16:57 -040011SRC_URI[md5sum] = "dfe130724d7c998eb26b56447e932899"
12SRC_URI[sha256sum] = "5cb66180143e6bfc774f4eb316206d40ac1cb6df269a90882404cbf7165513f5"
Brad Bishop26bdd442019-08-16 17:08:17 -040013
14inherit autotools manpages pkgconfig
15
16PACKAGECONFIG ?= "python"
17PACKAGECONFIG[man] = "--enable--man-doc, --disable-man-doc"
18PACKAGECONFIG[python] = "--with-python-bin=${PYTHON}, --with-python-bin="", python3"
19
20inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
21
22ASNEEDED = ""
23
24RRECOMMENDS_${PN} += "kernel-module-nf-tables"
25
26PACKAGES =+ "${PN}-python"
27FILES_${PN}-python = "${libdir_native}/${PYTHON_DIR}"
28RDEPENDS_${PN}-python = "python3-core python3-json"