blob: 06f3ee87da3ab3cfc240cc274ba35e4f02fd5ba1 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# Released under the MIT license (see COPYING.MIT for the terms)
2
3# Applications using this library needs to add link against libbreakpad_client.a.
4
5SUMMARY = "An open-source multi-platform crash reporting system"
6DESCRIPTION = "Breakpad is a library and tool suite that allows you to distribute an application to users with compiler-provided debugging information removed, record crashes in compact \"minidump\" files, send them back to your server, and produce C and C++ stack traces from these minidumps. "
7HOMEPAGE = "https://code.google.com/p/google-breakpad/"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=56c24a43c81c3af6fcf590851931489e"
10SECTION = "libs"
11
12inherit autotools
13
14BBCLASSEXTEND = "native"
15
Brad Bishop19323692019-04-05 15:28:33 -040016PE = "2"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017
Brad Bishop19323692019-04-05 15:28:33 -040018PV = "1.0"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020SRCREV_FORMAT = "breakpad_gtest_protobuf_lss_gyp"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021
Brad Bishop19323692019-04-05 15:28:33 -040022SRCREV_breakpad = "5467393a3d1e7ab929fd01d79971701bf4e2c2c6"
23#v1.8.0
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024SRCREV_gtest = "ec44c6c1675c25b9827aacd08c02433cccde7780"
25SRCREV_protobuf = "cb6dd4ef5f82e41e06179dcd57d3b1d9246ad6ac"
Brad Bishop19323692019-04-05 15:28:33 -040026SRCREV_lss = "a89bf7903f3169e6bc7b8efc10a73a7571de21cf"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050027SRCREV_gyp = "324dd166b7c0b39d513026fa52d6280ac6d56770"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028
29SRC_URI = "git://github.com/google/breakpad;name=breakpad \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030 git://github.com/google/googletest.git;destsuffix=git/src/testing/gtest;name=gtest \
31 git://github.com/google/protobuf.git;destsuffix=git/src/third_party/protobuf/protobuf;name=protobuf \
32 git://chromium.googlesource.com/linux-syscall-support;protocol=https;destsuffix=git/src/third_party/lss;name=lss \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033 git://chromium.googlesource.com/external/gyp;protocol=https;destsuffix=git/src/tools/gyp;name=gyp \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050034 file://0001-include-sys-reg.h-to-get-__WORDSIZE-on-musl-libc.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050035 file://0003-Fix-conflict-between-musl-libc-dirent.h-and-lss.patch \
36 file://0001-Turn-off-sign-compare-for-musl-libc.patch \
37 file://0002-sys-signal.h-is-a-nonportable-alias-for-signal.h.patch \
38 file://0003-Dont-include-stab.h.patch \
39 file://0004-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040 file://0002-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch \
41 file://mcontext.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040042 file://0001-disable-calls-to-getcontext-with-musl.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050043 file://0001-lss-Match-syscalls-to-match-musl.patch;patchdir=src/third_party/lss \
44 file://mips_asm_sgidefs.patch;patchdir=src/third_party/lss \
Brad Bishop0f291cc2019-09-01 15:16:57 -040045 file://dont-clobber-rsp.patch;patchdir=src/third_party/lss;striplevel=4 \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050046"
47S = "${WORKDIR}/git"
48
Brad Bishopd7bf8c12018-02-25 22:55:05 -050049CXXFLAGS += "-D_GNU_SOURCE"
50
Brad Bishop19323692019-04-05 15:28:33 -040051COMPATIBLE_HOST_powerpc = "null"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050052
53do_install_append() {
54 install -d ${D}${includedir}
55 install -d ${D}${includedir}/breakpad
56
57 install -d ${D}${includedir}/breakpad/client/linux/crash_generation
58 install -m 0644 ${S}/src/client/linux/crash_generation/crash_generation_client.h ${D}${includedir}/breakpad/client/linux/crash_generation/crash_generation_client.h
59
60 install -d ${D}${includedir}/breakpad/client/linux/handler/
61 install -m 0644 ${S}/src/client/linux/handler/exception_handler.h ${D}${includedir}/breakpad/client/linux/handler/exception_handler.h
62 install -m 0644 ${S}/src/client/linux/handler/minidump_descriptor.h ${D}${includedir}/breakpad/client/linux/handler/minidump_descriptor.h
63
64 install -d ${D}${includedir}/breakpad/client/linux/dump_writer_common
65 install -m 0644 ${S}/src/client/linux/dump_writer_common/mapping_info.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/mapping_info.h
66 install -m 0644 ${S}/src/client/linux/dump_writer_common/thread_info.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/thread_info.h
67 install -m 0644 ${S}/src/client/linux/dump_writer_common/raw_context_cpu.h ${D}${includedir}/breakpad/client/linux/dump_writer_common/raw_context_cpu.h
68
69 install -d ${D}${includedir}/breakpad/client/linux/minidump_writer
70 install -m 0644 ${S}/src/client/linux/minidump_writer/linux_dumper.h ${D}${includedir}/breakpad/client/linux/minidump_writer/linux_dumper.h
71 install -m 0644 ${S}/src/client/linux/minidump_writer/minidump_writer.h ${D}${includedir}/breakpad/client/linux/minidump_writer/minidump_writer.h
72
73 install -d ${D}${includedir}/breakpad/common
Brad Bishop19323692019-04-05 15:28:33 -040074 install -m 0644 ${S}/src/common/memory_allocator.h ${D}${includedir}/breakpad/common/memory_allocator.h
Brad Bishop6e60e8b2018-02-01 10:27:11 -050075 install -m 0644 ${S}/src/common/scoped_ptr.h ${D}${includedir}/breakpad/common/scoped_ptr.h
76 install -m 0644 ${S}/src/common/using_std_string.h ${D}${includedir}/breakpad/common/using_std_string.h
77
78 install -d ${D}${includedir}/breakpad/google_breakpad/common
79 install -m 0644 ${S}/src/google_breakpad/common/breakpad_types.h ${D}${includedir}/breakpad/google_breakpad/common/breakpad_types.h
80 install -m 0644 ${S}/src/google_breakpad/common/minidump_format.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_format.h
81 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_amd64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_amd64.h
82 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_arm.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_arm.h
Brad Bishopd7bf8c12018-02-25 22:55:05 -050083 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_arm64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_arm64.h
Brad Bishop6e60e8b2018-02-01 10:27:11 -050084 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_mips.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_mips.h
85 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_ppc64.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_ppc64.h
86 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_ppc.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_ppc.h
87 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_sparc.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_sparc.h
88 install -m 0644 ${S}/src/google_breakpad/common/minidump_cpu_x86.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_cpu_x86.h
89 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_linux.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_linux.h
90 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_mac.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_mac.h
91 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_ps3.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_ps3.h
92 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_solaris.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_solaris.h
93 install -m 0644 ${S}/src/google_breakpad/common/minidump_exception_win32.h ${D}${includedir}/breakpad/google_breakpad/common/minidump_exception_win32.h
94
95 install -d ${D}${includedir}/breakpad/third_party/lss
96 install -m 0644 ${S}/src/third_party/lss/linux_syscall_support.h ${D}${includedir}/breakpad/third_party/lss/linux_syscall_support.h
97}
98
99PACKAGES =+ "${PN}-minidump-upload ${PN}-sym-upload"
100
101FILES_${PN}-minidump-upload = "${bindir}/minidump_upload"
102FILES_${PN}-sym-upload = "${bindir}/sym_upload"
103
104
105SYSROOT_PREPROCESS_FUNCS += "breakpad_populate_sysroot"
106breakpad_populate_sysroot() {
107 sysroot_stage_dir ${D}/usr/include ${SYSROOT_DESTDIR}/usr/include
108 sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib
109 sysroot_stage_dir ${D}/usr/lib ${SYSROOT_DESTDIR}/usr/lib
110}
111
112# Fails to build with thumb-1 (qemuarm)
113#| {standard input}: Assembler messages:
114#| {standard input}:2178: Error: selected processor does not support Thumb mode `it ne'
115#| {standard input}:2179: Error: Thumb does not support conditional execution
116#| {standard input}:2180: Error: selected processor does not support Thumb mode `it eq'
117#| {standard input}:2181: Error: Thumb does not support conditional execution
118#| {standard input}:2183: Error: lo register required -- `str ip,[r1,#-4]!'
119#| {standard input}:2184: Error: Thumb does not support this addressing mode -- `str r6,[r1,#-4]!'
120#| {standard input}:2191: Error: lo register required -- `ldr pc,[sp]'
121#| make: *** [src/client/linux/handler/exception_handler.o] Error 1
Brad Bishop19323692019-04-05 15:28:33 -0400122ARM_INSTRUCTION_SET_armv5 = "arm"
123ARM_INSTRUCTION_SET_armv4 = "arm"