Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | require grub2.inc |
| 2 | |
| 3 | GRUBPLATFORM = "efi" |
| 4 | |
| 5 | DEPENDS_append_class-target = " grub-efi-native" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | RDEPENDS_${PN}_class-target = "diffutils freetype grub-common virtual/grub-bootconf" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 7 | |
| 8 | SRC_URI += " \ |
| 9 | file://cfg \ |
| 10 | " |
| 11 | |
| 12 | S = "${WORKDIR}/grub-${PV}" |
| 13 | |
| 14 | # Determine the target arch for the grub modules |
| 15 | python __anonymous () { |
| 16 | import re |
| 17 | target = d.getVar('TARGET_ARCH') |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 18 | prefix = "" if d.getVar('EFI_PROVIDER') == "grub-efi" else "grub-efi-" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 19 | if target == "x86_64": |
| 20 | grubtarget = 'x86_64' |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | grubimage = prefix + "bootx64.efi" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | elif re.match('i.86', target): |
| 23 | grubtarget = 'i386' |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 24 | grubimage = prefix + "bootia32.efi" |
| 25 | elif re.match('aarch64', target): |
| 26 | grubtarget = 'arm64' |
| 27 | grubimage = prefix + "bootaa64.efi" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | elif re.match('arm', target): |
| 29 | grubtarget = 'arm' |
| 30 | grubimage = prefix + "bootarm.efi" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 31 | else: |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 32 | raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target) |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 33 | d.setVar("GRUB_TARGET", grubtarget) |
| 34 | d.setVar("GRUB_IMAGE", grubimage) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | prefix = "grub-efi-" if prefix == "" else "" |
| 36 | d.setVar("GRUB_IMAGE_PREFIX", prefix) |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 37 | } |
| 38 | |
| 39 | inherit deploy |
| 40 | |
| 41 | CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN=" |
| 42 | EXTRA_OECONF += "--enable-efiemu=no" |
| 43 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 44 | do_mkimage() { |
| 45 | cd ${B} |
| 46 | # Search for the grub.cfg on the local boot media by using the |
| 47 | # built in cfg file provided via this recipe |
| 48 | grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \ |
| 49 | -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} \ |
| 50 | ${GRUB_BUILDIN} |
| 51 | } |
| 52 | |
| 53 | addtask mkimage before do_install after do_compile |
| 54 | |
| 55 | do_mkimage_class-native() { |
| 56 | : |
| 57 | } |
| 58 | |
| 59 | do_install_append_class-target() { |
| 60 | install -d ${D}/boot |
| 61 | install -d ${D}/boot/EFI |
| 62 | install -d ${D}/boot/EFI/BOOT |
| 63 | install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${D}/boot/EFI/BOOT/${GRUB_IMAGE} |
| 64 | } |
| 65 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 66 | do_install_class-native() { |
| 67 | install -d ${D}${bindir} |
| 68 | install -m 755 grub-mkimage ${D}${bindir} |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 69 | install -m 755 grub-editenv ${D}${bindir} |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 70 | } |
| 71 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 72 | do_install_class-target() { |
| 73 | oe_runmake 'DESTDIR=${D}' -C grub-core install |
| 74 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 75 | # Remove build host references... |
| 76 | find "${D}" -name modinfo.sh -type f -exec \ |
| 77 | sed -i \ |
| 78 | -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \ |
| 79 | -e 's|${DEBUG_PREFIX_MAP}||g' \ |
| 80 | -e 's:${RECIPE_SYSROOT_NATIVE}::g' \ |
| 81 | {} + |
| 82 | } |
| 83 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 84 | do_install_append_aarch64() { |
| 85 | rm -rf ${D}/${prefix}/ |
| 86 | } |
| 87 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 88 | GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 89 | efi_gop iso9660 configfile search loadenv test" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 90 | |
| 91 | do_deploy() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 92 | install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${DEPLOYDIR} |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 93 | } |
| 94 | |
| 95 | do_deploy_class-native() { |
| 96 | : |
| 97 | } |
| 98 | |
| 99 | addtask deploy after do_install before do_build |
| 100 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 101 | FILES_${PN} = "${libdir}/grub/${GRUB_TARGET}-efi \ |
| 102 | ${datadir}/grub \ |
| 103 | /boot/EFI/BOOT/${GRUB_IMAGE} \ |
| 104 | " |
| 105 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 106 | FILES_${PN}_remove_aarch64 = "${libdir}/grub/${GRUB_TARGET}-efi" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 107 | |
| 108 | # 64-bit binaries are expected for the bootloader with an x32 userland |
| 109 | INSANE_SKIP_${PN}_append_linux-gnux32 = " arch" |
| 110 | INSANE_SKIP_${PN}-dbg_append_linux-gnux32 = " arch" |
| 111 | INSANE_SKIP_${PN}_append_linux-muslx32 = " arch" |
| 112 | INSANE_SKIP_${PN}-dbg_append_linux-muslx32 = " arch" |