blob: 717f5030393261d734ef0f625fd80dc291ae2250 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Tool to produce a statistics based on a diff"
2DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
3the insertions, deletions, and modifications per-file. It is useful for \
4reviewing large, complex patch files."
5HOMEPAGE = "http://invisible-island.net/diffstat/"
6SECTION = "devel"
7LICENSE = "MIT"
Andrew Geisslerd1e89492021-02-12 15:35:20 -06008LIC_FILES_CHKSUM = "file://COPYING;md5=f605b1986cc3b808ec0e4fa9d0e0f2d9"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
11 file://run-ptest \
12 file://avoid-check-user-break-cc.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 "
14
Andrew Geisslerd1e89492021-02-12 15:35:20 -060015SRC_URI[sha256sum] = "b8aee38d9d2e1d05926e6b55810a9d2c2dd407f24d6a267387563a4436e3f7fc"
Andrew Geissler706d5aa2021-02-12 15:55:30 -060016
Andrew Geissler82c905d2020-04-13 13:39:40 -050017inherit autotools gettext ptest
18
19EXTRA_AUTORECONF += "--exclude=aclocal"
20
21LDFLAGS += "${TOOLCHAIN_OPTIONS}"
22
23do_install_ptest() {
24 cp -r ${S}/testing ${D}${PTEST_PATH}
25}
Andrew Geissler6ce62a22020-11-30 19:58:47 -060026
27BBCLASSEXTEND = "nativesdk"