blob: 43eb60b33c1d1a0d636c6d98a57d7bfc78305b47 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Brad Bishop6dbb3162019-11-25 09:41:34 -05008 "
Andrew Geisslerd1e89492021-02-12 15:35:20 -06009SRC_URI[sha256sum] = "eb0484e568ead8fa23b513e9b0041df7e327f4ee2d22db5a533929dfc19633cb"
Brad Bishop19323692019-04-05 15:28:33 -040010
11# exclude betas
12UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
13
14inherit autotools multilib_header
15
16CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
17
18PACKAGECONFIG ?= "cxx jpeg zlib lzma \
19 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
20
21PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
22PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
23PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
24PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
25
26# Convert single-strip uncompressed images to multiple strips of specified
27# size (default: 8192) to reduce memory usage
28PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
29
30# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
31PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
32
33# Control picking up YCbCr subsample info. Disable to support files lacking
34# the tag
35PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
36
37# Support a mechanism allowing reading large strips (usually one strip files)
38# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
39PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
40
41PACKAGES =+ "tiffxx tiff-utils"
42FILES_tiffxx = "${libdir}/libtiffxx.so.*"
43FILES_tiff-utils = "${bindir}/*"
44
45do_install_append() {
46 oe_multilib_header tiffconf.h
47}
48
Andrew Geissler4ed12e12020-06-05 18:00:41 -050049BBCLASSEXTEND = "native nativesdk"