blob: c91fb7bd824b1cff955badb58b81ae7da8e99733 [file] [log] [blame]
Brad Bishop21f39fd2017-01-17 09:14:15 -05001SUMMARY = "Phosphor IPMI Inventory Plugin"
2DESCRIPTION = "A Phosphor IPMI plugin that updates inventory."
Chris Austen764ae432015-11-01 22:27:34 -06003PR = "r1"
Patrick Venturef6973802018-10-01 20:56:22 -07004PV = "1.0+git${SRCPV}"
Chris Austen764ae432015-11-01 22:27:34 -06005
Matthew Barthfc77ec42016-10-19 16:00:49 -05006inherit autotools pkgconfig
Brad Bishop1d525fa2016-08-17 20:27:37 -04007inherit obmc-phosphor-systemd
Tom Josephdcdc8ea2017-02-01 19:47:27 +05308inherit obmc-phosphor-ipmiprovider-symlink
Brad Bishop2f63e8c2017-01-28 13:00:52 -05009inherit phosphor-ipmi-fru
Andrew Geissler35c7c072020-04-04 07:31:23 +000010inherit python3native
Chris Austen764ae432015-11-01 22:27:34 -060011
Patrick Williamsfb700fd2020-04-03 15:48:30 -050012require ${BPN}.inc
Brad Bishop5bb8e372017-01-17 10:10:02 -050013
Brad Bishopcbac7fc2016-06-13 12:53:41 -040014DEPENDS += " \
Brad Bishop2f63e8c2017-01-28 13:00:52 -050015 virtual/phosphor-ipmi-fru-inventory \
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060016 virtual/phosphor-ipmi-fru-properties \
Brad Bishopcbac7fc2016-06-13 12:53:41 -040017 systemd \
Deepak Kodihallic11cbc52017-02-16 07:50:37 -060018 sdbusplus \
Andrew Geissler35c7c072020-04-04 07:31:23 +000019 ${PYTHON_PN}-mako-native \
20 ${PYTHON_PN}-pyyaml-native \
Brad Bishopceb1c9a2017-01-17 10:07:14 -050021 phosphor-ipmi-host \
Matthew Barthfc77ec42016-10-19 16:00:49 -050022 phosphor-mapper \
23 autoconf-archive-native \
Patrick Venture5508db22018-10-16 19:50:55 -070024 phosphor-logging \
Patrick Venturee4ccd822019-03-26 11:07:32 -070025 cli11 \
Brad Bishopcbac7fc2016-06-13 12:53:41 -040026 "
Chris Austen764ae432015-11-01 22:27:34 -060027
Patrick Williams12fc9392021-08-06 09:16:53 -050028RDEPENDS:${PN} += "bash"
William A. Kennington III147a7952020-03-30 12:03:28 -070029
30SRC_URI += "file://of-name-to-eeprom.sh"
31
Patrick Williams12fc9392021-08-06 09:16:53 -050032SYSTEMD_SERVICE:${PN} += "obmc-read-eeprom@.service"
Chris Austen764ae432015-11-01 22:27:34 -060033
Chris Austen764ae432015-11-01 22:27:34 -060034S = "${WORKDIR}/git"
35
Tom Josephdcdc8ea2017-02-01 19:47:27 +053036HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
37
Patrick Williams12fc9392021-08-06 09:16:53 -050038FILES:${PN} += "${bindir}/of-name-to-eeprom.sh"
39FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
40FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
41FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop2f63e8c2017-01-28 13:00:52 -050042
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060043EXTRA_OECONF = " \
44 YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml \
Ratan Gupta338899a2017-03-30 14:32:02 +053045 PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/extra-properties.yaml \
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060046 "
William A. Kennington III147a7952020-03-30 12:03:28 -070047
Patrick Williams12fc9392021-08-06 09:16:53 -050048do_install:append() {
William A. Kennington III147a7952020-03-30 12:03:28 -070049 install -d ${D}${bindir}
50 install -m 0755 ${WORKDIR}/of-name-to-eeprom.sh ${D}${bindir}
51}