blob: 62d19ec82e998ea836515e4e453c671b0311cee5 [file] [log] [blame]
Joel Stanleye8f268e2018-04-23 10:50:44 +09301HOMEPAGE = "https://github.com/jk-ozlabs/uart-render-controller"
2LICENSE = "GPLv2+"
3
4SRC_URI += "git://github.com/jk-ozlabs/uart-render-controller;branch=master"
5SRC_URI += "file://uart-render-controller.service"
6
7PR = "r1"
8
9LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
10
11inherit autotools
12inherit pkgconfig
13inherit systemd
14
15DEPENDS += "autoconf-archive-native"
16DEPENDS += "systemd"
Patrick Williams12fc9392021-08-06 09:16:53 -050017RDEPENDS:${PN} += "fbterm"
Joel Stanleye8f268e2018-04-23 10:50:44 +093018
Jeremy Kerr711fbc32019-08-01 15:23:18 +080019SRCREV = "26ac7f7bd6af52db63451d3633bcf1b167eea3d1"
Joel Stanleye8f268e2018-04-23 10:50:44 +093020PV = "0.1+git${SRCPV}"
21
22S = "${WORKDIR}/git"
23
Patrick Williams12fc9392021-08-06 09:16:53 -050024SYSTEMD_SERVICE:${PN} += "uart-render-controller.service"
Joel Stanleye8f268e2018-04-23 10:50:44 +093025
Patrick Williams12fc9392021-08-06 09:16:53 -050026do_install:append() {
Joel Stanleye8f268e2018-04-23 10:50:44 +093027 install -d ${D}${systemd_system_unitdir}
28 install -m 0644 ${WORKDIR}/uart-render-controller.service ${D}${systemd_system_unitdir}/
29}