blob: 552f81df0adbb8fede33ba9fd7f7133ab3b52a92 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4
5SUMMARY = "Simple Protocol for Independent Computing Environments"
6DESCRIPTION = "SPICE (the Simple Protocol for Independent Computing \
7Environments) is a remote-display system built for virtual \
8environments which allows users to view a computing 'desktop' \
9environment - not only on its computer-server machine, but also from \
10anywhere on the Internet and using a wide variety of machine \
11architectures."
12
13LICENSE = "BSD & LGPLv2.1+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
15
Brad Bishop15ae2502019-06-18 21:44:24 -040016PV = "0.14.2+git${SRCPV}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017
Brad Bishop15ae2502019-06-18 21:44:24 -040018SRCREV_spice = "7cbd70b931db76c69c89c2d9d5d704f67381a81b"
19SRCREV_spice-common = "4fc4c2db36c7f07b906e9a326a9d3dc0ae6a2671"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21SRCREV_FORMAT = "spice_spice-common"
22
23SRC_URI = " \
24 git://anongit.freedesktop.org/spice/spice;name=spice \
25 git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common \
26 file://0001-Convert-pthread_t-to-be-numeric.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040027 file://0001-Fix-compile-errors-on-Linux-32bit-system.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028"
29
30S = "${WORKDIR}/git"
31
32inherit autotools gettext pythonnative python-dir pkgconfig
33
34DEPENDS += "spice-protocol jpeg pixman alsa-lib glib-2.0 python-pyparsing-native python-six-native glib-2.0-native"
35DEPENDS_append_class-nativesdk = "nativesdk-openssl"
36
37export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python"
38export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages"
39
Brad Bishop15ae2502019-06-18 21:44:24 -040040CFLAGS_append = " -Wno-error=address-of-packed-member"
41
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042PACKAGECONFIG_class-native = ""
43PACKAGECONFIG_class-nativesdk = ""
44PACKAGECONFIG ?= "sasl"
45
46PACKAGECONFIG[celt051] = "--enable-celt051,--disable-celt051,celt051"
47PACKAGECONFIG[smartcard] = "--enable-smartcard,--disable-smartcard,libcacard,"
48PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,"
49PACKAGECONFIG[client] = "--enable-client,--disable-client,,"
50PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,,"
51PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus,"
52PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,,"
53PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama,"
54
55COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
56
57BBCLASSEXTEND = "native nativesdk"
58
Brad Bishop15ae2502019-06-18 21:44:24 -040059EXTRA_OECONF_append_toolchain-clang = " --disable-werror"