blob: 8254a85fc92b49c6403d9b282899ffc43f86bef9 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
2DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
4LICENSE = "GPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit gnomebase gettext systemd vala gobject-introspection bash-completion
11
Brad Bishop19323692019-04-05 15:28:33 -040012DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native libxslt-native"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \
Andrew Geissler1548c072019-02-22 16:03:50 -060015 file://0001-Do-not-set-Wno-unused-but-set-variable.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016 "
Brad Bishop15ae2502019-06-18 21:44:24 -040017SRC_URI[md5sum] = "92d25176d0cc9d588ca29700b33c7d98"
18SRC_URI[sha256sum] = "fd0f39996025dac96995daea8a58ec7dd571582f7563a8ae0d5f65b571b76ee2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
20S = "${WORKDIR}/ModemManager-${PV}"
21
Brad Bishop19323692019-04-05 15:28:33 -040022PACKAGECONFIG ??= "mbim qmi \
23 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024"
25
26PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,"
27PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit"
28# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
Brad Bishop19323692019-04-05 15:28:33 -040029PACKAGECONFIG[mbim] = "--with-mbim,--without-mbim,libmbim"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
31PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi"
32
33EXTRA_OECONF = " \
34 --with-udev-base-dir=${nonarch_base_libdir}/udev \
35"
Andrew Geissler1548c072019-02-22 16:03:50 -060036CFLAGS_append_toolchain-gcc = " -Wno-unused-but-set-variable"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037
38FILES_${PN} += " \
39 ${datadir}/icons \
40 ${datadir}/polkit-1 \
41 ${datadir}/dbus-1 \
42 ${libdir}/ModemManager \
43 ${systemd_unitdir}/system \
44"
45
46FILES_${PN}-dev += " \
47 ${libdir}/ModemManager/*.la \
48"
49
50FILES_${PN}-staticdev += " \
51 ${libdir}/ModemManager/*.a \
52"
53
54FILES_${PN}-dbg += "${libdir}/ModemManager/.debug"
55
56SYSTEMD_SERVICE_${PN} = "ModemManager.service"