blob: d0e1a29ddfe05a899e8050409f89002895759500 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "haveged - A simple entropy daemon"
2DESCRIPTION = "The haveged project is an attempt to provide an easy-to-use, unpredictable random number generator based upon an adaptation of the HAVEGE algorithm. Haveged was created to remedy low-entropy conditions in the Linux random device that can occur under some workloads, especially on headless servers."
3AUTHOR = "Gary Wuertz"
4HOMEPAGE = "http://www.issihosts.com/haveged/index.html"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM="file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8# v1.9.4
9SRCREV = "faa40ff345af194d3253f5fb030403e3c9831c36"
10SRC_URI = "git://github.com/jirka-h/haveged.git \
11 file://haveged-init.d-Makefile.am-add-missing-dependency.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040012 file://fix-cpu-cache-size-detection.patch \
Brad Bishop19323692019-04-05 15:28:33 -040013"
14S = "${WORKDIR}/git"
15
16UPSTREAM_CHECK_URI = "https://github.com/jirka-h/haveged/releases"
17
18inherit autotools update-rc.d systemd
19
20EXTRA_OECONF = "\
21 --enable-nistest=yes \
22 --enable-olt=yes \
23 --enable-threads=no \
24"
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
27PACKAGECONFIG[systemd] = "--enable-init=service.redhat --enable-initdir=${systemd_system_unitdir}, --enable-init=sysv.redhat, systemd"
28
29INITSCRIPT_PACKAGES = "${PN}"
30INITSCRIPT_NAME = "haveged"
31INITSCRIPT_PARAMS_${PN} = "defaults 9"
32
33SYSTEMD_PACKAGES = "${PN}"
34SYSTEMD_SERVICE_${PN} = "haveged.service"
35
36do_install_append() {
37 # The exit status is 143 when the service is stopped
38 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
39 sed -i '/ExecStart/a SuccessExitStatus=143' ${D}${systemd_system_unitdir}/haveged.service
40 fi
41}
42
43MIPS_INSTRUCTION_SET = "mips"