blob: 8754383efa583fe4ecae62d607e9eb64c20cba30 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "PolicyKit Authorization Framework"
2DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit"
4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
7
8DEPENDS = "expat glib-2.0 intltool-native mozjs"
9
Brad Bishop19323692019-04-05 15:28:33 -040010inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection distro_features_check
11
12REQUIRED_DISTRO_FEATURES = "polkit"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
15 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', \
16 bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \
17 "
18
19PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
20PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd"
21# there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS
22PACKAGECONFIG[consolekit] = ",,,consolekit"
23
24PAM_SRC_URI = "file://polkit-1_pam.patch"
25SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
Brad Bishop15ae2502019-06-18 21:44:24 -040026 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
27 file://0003-make-netgroup-support-optional.patch \
28 "
29SRC_URI[md5sum] = "4b37258583393e83069a0e2e89c0162a"
30SRC_URI[sha256sum] = "88170c9e711e8db305a12fdb8234fac5706c61969b94e084d0f117d8ec5d34b1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
32EXTRA_OECONF = "--with-os-type=moblin \
33 --disable-man-pages \
34 --disable-libelogind \
35 "
36
37do_compile_prepend () {
38 export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs"
39}
40
41PACKAGES =+ "${PN}-examples"
42
43FILES_${PN}_append = " \
44 ${libdir}/${BPN}-1 \
45 ${nonarch_libdir}/${BPN}-1 \
46 ${datadir}/dbus-1 \
47 ${datadir}/${BPN}-1 \
48 ${datadir}/gettext \
49"
50
51FILES_${PN}-examples = "${bindir}/*example*"
52
53USERADD_PACKAGES = "${PN}"
54USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd"
55
56SYSTEMD_SERVICE_${PN} = "${BPN}.service"
57SYSTEMD_AUTO_ENABLE = "disable"