blob: fb9bdc70fa5d012271baf7bc3f5f252e40f7b0af [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Opus Audio Codec"
2DESCRIPTION = "The Opus codec is designed for interactive \
3speech and audio transmission over the Internet. It is \
4designed by the IETF Codec Working Group and incorporates \
5technology from Skype's SILK codec and Xiph.Org's CELT codec."
6HOMEPAGE = "http://www.opus-codec.org/"
7SECTION = "libs/multimedia"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;md5=e304cdf74c2a1b0a33a5084c128a23a3"
10
11SRC_URI = "http://downloads.xiph.org/releases/opus/opus-${PV}.tar.gz"
12SRC_URI[md5sum] = "32bbb6b557fe1b6066adc0ae1f08b629"
13SRC_URI[sha256sum] = "58b6fe802e7e30182e95d0cde890c0ace40b6f125cffc50635f0ad2eef69b633"
14
15S = "${WORKDIR}/opus-${PV}"
16
17inherit autotools pkgconfig
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[fixed-point] = "--enable-fixed-point,,"
21PACKAGECONFIG[float-approx] = "--enable-float-approx,,"
22
23EXTRA_OECONF = " \
24 --with-NE10-includes=${STAGING_DIR_TARGET}${includedir} \
25 --with-NE10-libraries=${STAGING_DIR_TARGET}${libdir} \
26 --enable-asm \
27 --enable-intrinsics \
28 --enable-custom-modes \
29"
30
Brad Bishop15ae2502019-06-18 21:44:24 -040031# ne10 is available only for armv7a, armv7ve and aarch64
Brad Bishopc342db32019-05-15 21:57:59 -040032DEPENDS_append_aarch64 = " ne10"
33DEPENDS_append_armv7a = " ne10"
Brad Bishop15ae2502019-06-18 21:44:24 -040034DEPENDS_append_armv7ve = " ne10"
Brad Bishopc342db32019-05-15 21:57:59 -040035
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036python () {
37 if d.getVar('TARGET_FPU') in [ 'soft' ]:
38 d.appendVar('PACKAGECONFIG', ' fixed-point')
Brad Bishop6e60e8b2018-02-01 10:27:11 -050039}
40
41# Fails to build with thumb-1 (qemuarm)
42#| {standard input}: Assembler messages:
43#| {standard input}:389: Error: selected processor does not support Thumb mode `smull r5,r7,r1,r4'
44#| {standard input}:418: Error: selected processor does not support Thumb mode `smull r5,r6,r4,r1'
45#| {standard input}:448: Error: selected processor does not support Thumb mode `smull r4,r5,r1,r0'
46#| {standard input}:474: Error: selected processor does not support Thumb mode `smull r0,r4,r8,r1'
47#| {standard input}:510: Error: selected processor does not support Thumb mode `smull fp,r0,r10,r1'
48#| {standard input}:553: Error: selected processor does not support Thumb mode `smull fp,r1,r10,r3'
49#| {standard input}:741: Error: selected processor does not support Thumb mode `smull r3,r0,r6,r10'
50#| {standard input}:761: Error: selected processor does not support Thumb mode `smull fp,r2,r3,r9'
51#| {standard input}:773: Error: selected processor does not support Thumb mode `smull fp,r3,r5,r8'
52#| make[2]: *** [celt/celt.lo] Error 1
53ARM_INSTRUCTION_SET = "arm"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054
55BBCLASSEXTEND = "native nativesdk"