blob: fd02f4a76be6adcf2f8292d09311cd614fb59be6 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A graphical front-end for gcov"
2HOMEPAGE = "http://ltp.sourceforge.net/coverage/lcov.php"
3DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \
4tool gcov. It collects gcov data for multiple source files and creates \
5HTML pages containing the source code annotated with coverage information. \
6It also adds overview pages for easy navigation within the file structure. \
Patrick Williamsddad1a12017-02-23 20:36:32 -06007LCOV supports statement, function and branch coverage measurement."
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008LICENSE = "GPL-2.0"
9LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
10
11RDEPENDS_${PN} += " \
12 gcov \
13 perl \
14 perl-module-filehandle \
15 perl-module-getopt-std \
16 perl-module-digest-sha \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017 perl-module-constant \
18 perl-module-cwd \
19 perl-module-errno \
20 perl-module-file-basename \
21 perl-module-file-find \
22 perl-module-file-path \
23 perl-module-file-spec \
24 perl-module-file-spec-functions \
25 perl-module-file-spec-unix \
26 perl-module-file-temp \
27 perl-module-getopt-long \
28 perl-module-list-util \
29 perl-module-mro \
30 perl-module-overload \
31 perl-module-overloading \
32 perl-module-overload-numbers \
33 perl-module-parent \
34 perl-module-pod-usage \
35 perl-module-posix \
36 perl-module-re \
37 perl-module-safe \
38 perl-module-scalar-util \
39 perl-module-term-cap \
40 perl-module-text-parsewords \
41 perl-module-tie-hash \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050042"
43
44SRC_URI = "http://downloads.sourceforge.net/ltp/${BP}.tar.gz"
45
Brad Bishop15ae2502019-06-18 21:44:24 -040046SRC_URI[md5sum] = "0220d01753469f83921f8f41ae5054c1"
47SRC_URI[sha256sum] = "14995699187440e0ae4da57fe3a64adc0a3c5cf14feab971f8db38fb7d8f071a"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050048
49do_install() {
Brad Bishop15ae2502019-06-18 21:44:24 -040050 oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir}
Patrick Williamsb48b7b42016-08-17 15:04:38 -050051}
52