blob: a4b200a7e84737f26670311dfe7f97e42f94523d [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Xfce4 Panel"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
5DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ gtk+3 dbus cairo virtual/libx11 libxml2 libwnck3 vala-native"
6
7inherit xfce gtk-doc gobject-introspection distro_features_check gtk-icon-cache remove-libtool
8
9REQUIRED_DISTRO_FEATURES = "x11"
10
Brad Bishop15ae2502019-06-18 21:44:24 -040011SRC_URI[md5sum] = "376e360fb87095edaea7df8ca34fe6a7"
12SRC_URI[sha256sum] = "0d05b6dd8c91c154a364a3e31583c5f423c33e26d44d43cc409165f7d578ca15"
Brad Bishop19323692019-04-05 15:28:33 -040013SRC_URI += " \
14 file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
15"
16
17python populate_packages_prepend() {
18 plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/')
19 plugin_name = d.expand('${PN}-plugin-%s')
20 do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
21 '${PN} plugin for %s', extra_depends='', prepend=True,
22 aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop',
23 '${sysconfdir}/xdg/xfce/panel/%s-*',
24 '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
25 '${bindir}/*%s*'])
26}
27
28PACKAGES_DYNAMIC += "^${PN}-plugin-.*"
29
30PACKAGES =+ "${PN}-gtk3"
31
32FILES_${PN} += "${libdir}/xfce4/panel/migrate \
33 ${libdir}/xfce4/panel/wrapper-1.0"
34
35FILES_${PN}-dev += "${libdir}/xfce4/panel/plugins/*.la"
36
37FILES_${PN}-gtk3 = " \
38 ${libdir}/libxfce4panel-2.0${SOLIBS} \
39 ${libdir}/xfce4/panel/wrapper-2.0 \
40"