blob: 9e224daf057efe152e81051a2e45cd8e45ffffce [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001inherit kernel-uboot kernel-artifact-names uboot-sign
Patrick Williamsc124f4f2015-09-15 14:41:29 -05002
3python __anonymous () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004 kerneltypes = d.getVar('KERNEL_IMAGETYPES') or ""
He Zhefe76b1e2016-05-25 04:47:16 -04005 if 'fitImage' in kerneltypes.split():
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006 depends = d.getVar("DEPENDS")
Brad Bishop19323692019-04-05 15:28:33 -04007 depends = "%s u-boot-tools-native dtc-native" % depends
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008 d.setVar("DEPENDS", depends)
9
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010 uarch = d.getVar("UBOOT_ARCH")
11 if uarch == "arm64":
12 replacementtype = "Image"
Brad Bishopc342db32019-05-15 21:57:59 -040013 elif uarch == "riscv":
14 replacementtype = "Image"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015 elif uarch == "mips":
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016 replacementtype = "vmlinuz.bin"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017 elif uarch == "x86":
Patrick Williamsc0f7c042017-02-23 20:41:17 -060018 replacementtype = "bzImage"
Brad Bishop316dfdd2018-06-25 12:45:53 -040019 elif uarch == "microblaze":
20 replacementtype = "linux.bin"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021 else:
22 replacementtype = "zImage"
23
Brad Bishop19323692019-04-05 15:28:33 -040024 # Override KERNEL_IMAGETYPE_FOR_MAKE variable, which is internal
25 # to kernel.bbclass . We have to override it, since we pack zImage
26 # (at least for now) into the fitImage .
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027 typeformake = d.getVar("KERNEL_IMAGETYPE_FOR_MAKE") or ""
He Zhefe76b1e2016-05-25 04:47:16 -040028 if 'fitImage' in typeformake.split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -060029 d.setVar('KERNEL_IMAGETYPE_FOR_MAKE', typeformake.replace('fitImage', replacementtype))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031 image = d.getVar('INITRAMFS_IMAGE')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032 if image:
George McCollister185c8ae2016-05-26 08:55:16 -050033 d.appendVarFlag('do_assemble_fitimage_initramfs', 'depends', ' ${INITRAMFS_IMAGE}:do_image_complete')
34
Brad Bishop19323692019-04-05 15:28:33 -040035 #check if there are any dtb providers
36 providerdtb = d.getVar("PREFERRED_PROVIDER_virtual/dtb")
37 if providerdtb:
38 d.appendVarFlag('do_assemble_fitimage', 'depends', ' virtual/dtb:do_populate_sysroot')
39 d.appendVarFlag('do_assemble_fitimage_initramfs', 'depends', ' virtual/dtb:do_populate_sysroot')
40 d.setVar('EXTERNAL_KERNEL_DEVICETREE', "${RECIPE_SYSROOT}/boot/devicetree")
41
Patrick Williamsc0f7c042017-02-23 20:41:17 -060042 # Verified boot will sign the fitImage and append the public key to
Brad Bishop6e60e8b2018-02-01 10:27:11 -050043 # U-Boot dtb. We ensure the U-Boot dtb is deployed before assembling
Patrick Williamsc0f7c042017-02-23 20:41:17 -060044 # the fitImage:
Brad Bishop15ae2502019-06-18 21:44:24 -040045 if d.getVar('UBOOT_SIGN_ENABLE') == "1" and d.getVar('UBOOT_DTB_BINARY'):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050046 uboot_pn = d.getVar('PREFERRED_PROVIDER_u-boot') or 'u-boot'
Brad Bishop19323692019-04-05 15:28:33 -040047 d.appendVarFlag('do_assemble_fitimage', 'depends', ' %s:do_populate_sysroot' % uboot_pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048}
49
Yannick Gicqueld5813b42016-04-27 16:20:55 +020050# Options for the device tree compiler passed to mkimage '-D' feature:
51UBOOT_MKIMAGE_DTCOPTS ??= ""
52
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053#
54# Emit the fitImage ITS header
55#
George McCollister185c8ae2016-05-26 08:55:16 -050056# $1 ... .its filename
Patrick Williamsc124f4f2015-09-15 14:41:29 -050057fitimage_emit_fit_header() {
George McCollister185c8ae2016-05-26 08:55:16 -050058 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050059/dts-v1/;
60
61/ {
62 description = "U-Boot fitImage for ${DISTRO_NAME}/${PV}/${MACHINE}";
63 #address-cells = <1>;
64EOF
65}
66
67#
68# Emit the fitImage section bits
69#
George McCollister185c8ae2016-05-26 08:55:16 -050070# $1 ... .its filename
71# $2 ... Section bit type: imagestart - image section start
Patrick Williamsc124f4f2015-09-15 14:41:29 -050072# confstart - configuration section start
73# sectend - section end
74# fitend - fitimage end
75#
76fitimage_emit_section_maint() {
George McCollister185c8ae2016-05-26 08:55:16 -050077 case $2 in
Patrick Williamsc124f4f2015-09-15 14:41:29 -050078 imagestart)
George McCollister185c8ae2016-05-26 08:55:16 -050079 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050080
81 images {
82EOF
83 ;;
84 confstart)
George McCollister185c8ae2016-05-26 08:55:16 -050085 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050086
87 configurations {
88EOF
89 ;;
90 sectend)
George McCollister185c8ae2016-05-26 08:55:16 -050091 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050092 };
93EOF
94 ;;
95 fitend)
George McCollister185c8ae2016-05-26 08:55:16 -050096 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050097};
98EOF
99 ;;
100 esac
101}
102
103#
104# Emit the fitImage ITS kernel section
105#
George McCollister185c8ae2016-05-26 08:55:16 -0500106# $1 ... .its filename
107# $2 ... Image counter
108# $3 ... Path to kernel image
109# $4 ... Compression type
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500110fitimage_emit_section_kernel() {
111
112 kernel_csum="sha1"
113
Brad Bishop316dfdd2018-06-25 12:45:53 -0400114 ENTRYPOINT="${UBOOT_ENTRYPOINT}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500115 if [ -n "${UBOOT_ENTRYSYMBOL}" ]; then
116 ENTRYPOINT=`${HOST_PREFIX}nm vmlinux | \
117 awk '$3=="${UBOOT_ENTRYSYMBOL}" {print "0x"$1;exit}'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500118 fi
119
George McCollister185c8ae2016-05-26 08:55:16 -0500120 cat << EOF >> ${1}
121 kernel@${2} {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500122 description = "Linux kernel";
George McCollister185c8ae2016-05-26 08:55:16 -0500123 data = /incbin/("${3}");
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500124 type = "kernel";
125 arch = "${UBOOT_ARCH}";
126 os = "linux";
George McCollister185c8ae2016-05-26 08:55:16 -0500127 compression = "${4}";
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500128 load = <${UBOOT_LOADADDRESS}>;
129 entry = <${ENTRYPOINT}>;
130 hash@1 {
131 algo = "${kernel_csum}";
132 };
133 };
134EOF
135}
136
137#
138# Emit the fitImage ITS DTB section
139#
George McCollister185c8ae2016-05-26 08:55:16 -0500140# $1 ... .its filename
141# $2 ... Image counter
142# $3 ... Path to DTB image
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500143fitimage_emit_section_dtb() {
144
145 dtb_csum="sha1"
146
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800147 dtb_loadline=""
148 dtb_ext=${DTB##*.}
149 if [ "${dtb_ext}" = "dtbo" ]; then
150 if [ -n "${UBOOT_DTBO_LOADADDRESS}" ]; then
151 dtb_loadline="load = <${UBOOT_DTBO_LOADADDRESS}>;"
152 fi
153 elif [ -n "${UBOOT_DTB_LOADADDRESS}" ]; then
154 dtb_loadline="load = <${UBOOT_DTB_LOADADDRESS}>;"
155 fi
George McCollister185c8ae2016-05-26 08:55:16 -0500156 cat << EOF >> ${1}
157 fdt@${2} {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500158 description = "Flattened Device Tree blob";
George McCollister185c8ae2016-05-26 08:55:16 -0500159 data = /incbin/("${3}");
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500160 type = "flat_dt";
161 arch = "${UBOOT_ARCH}";
162 compression = "none";
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800163 ${dtb_loadline}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500164 hash@1 {
165 algo = "${dtb_csum}";
166 };
167 };
168EOF
169}
170
171#
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600172# Emit the fitImage ITS setup section
173#
174# $1 ... .its filename
175# $2 ... Image counter
176# $3 ... Path to setup image
177fitimage_emit_section_setup() {
178
179 setup_csum="sha1"
180
181 cat << EOF >> ${1}
182 setup@${2} {
183 description = "Linux setup.bin";
184 data = /incbin/("${3}");
185 type = "x86_setup";
186 arch = "${UBOOT_ARCH}";
187 os = "linux";
188 compression = "none";
189 load = <0x00090000>;
190 entry = <0x00090000>;
191 hash@1 {
192 algo = "${setup_csum}";
193 };
194 };
195EOF
196}
197
198#
George McCollister185c8ae2016-05-26 08:55:16 -0500199# Emit the fitImage ITS ramdisk section
200#
201# $1 ... .its filename
202# $2 ... Image counter
203# $3 ... Path to ramdisk image
204fitimage_emit_section_ramdisk() {
205
206 ramdisk_csum="sha1"
Rick Altherrbc1b8802017-01-20 11:28:53 -0800207 ramdisk_ctype="none"
Nathan Rossib4a4dc02016-10-21 22:07:27 +1000208 ramdisk_loadline=""
209 ramdisk_entryline=""
210
211 if [ -n "${UBOOT_RD_LOADADDRESS}" ]; then
212 ramdisk_loadline="load = <${UBOOT_RD_LOADADDRESS}>;"
213 fi
214 if [ -n "${UBOOT_RD_ENTRYPOINT}" ]; then
215 ramdisk_entryline="entry = <${UBOOT_RD_ENTRYPOINT}>;"
216 fi
George McCollister185c8ae2016-05-26 08:55:16 -0500217
Rick Altherrbc1b8802017-01-20 11:28:53 -0800218 case $3 in
219 *.gz)
220 ramdisk_ctype="gzip"
221 ;;
222 *.bz2)
223 ramdisk_ctype="bzip2"
224 ;;
225 *.lzma)
226 ramdisk_ctype="lzma"
227 ;;
228 *.lzo)
229 ramdisk_ctype="lzo"
230 ;;
231 *.lz4)
232 ramdisk_ctype="lz4"
233 ;;
234 esac
235
George McCollister185c8ae2016-05-26 08:55:16 -0500236 cat << EOF >> ${1}
237 ramdisk@${2} {
Rick Altherrbc1b8802017-01-20 11:28:53 -0800238 description = "${INITRAMFS_IMAGE}";
George McCollister185c8ae2016-05-26 08:55:16 -0500239 data = /incbin/("${3}");
240 type = "ramdisk";
241 arch = "${UBOOT_ARCH}";
242 os = "linux";
Rick Altherrbc1b8802017-01-20 11:28:53 -0800243 compression = "${ramdisk_ctype}";
Nathan Rossib4a4dc02016-10-21 22:07:27 +1000244 ${ramdisk_loadline}
245 ${ramdisk_entryline}
George McCollister185c8ae2016-05-26 08:55:16 -0500246 hash@1 {
247 algo = "${ramdisk_csum}";
248 };
249 };
250EOF
251}
252
253#
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500254# Emit the fitImage ITS configuration section
255#
George McCollister185c8ae2016-05-26 08:55:16 -0500256# $1 ... .its filename
257# $2 ... Linux kernel ID
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500258# $3 ... DTB image name
George McCollister185c8ae2016-05-26 08:55:16 -0500259# $4 ... ramdisk ID
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600260# $5 ... config ID
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500261# $6 ... default flag
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500262fitimage_emit_section_config() {
263
264 conf_csum="sha1"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600265 if [ -n "${UBOOT_SIGN_ENABLE}" ] ; then
266 conf_sign_keyname="${UBOOT_SIGN_KEYNAME}"
267 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500268
269 # Test if we have any DTBs at all
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800270 sep=""
271 conf_desc=""
272 kernel_line=""
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600273 fdt_line=""
274 ramdisk_line=""
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500275 setup_line=""
276 default_line=""
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600277
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800278 if [ -n "${2}" ]; then
279 conf_desc="Linux kernel"
280 sep=", "
281 kernel_line="kernel = \"kernel@${2}\";"
282 fi
283
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600284 if [ -n "${3}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800285 conf_desc="${conf_desc}${sep}FDT blob"
286 sep=", "
George McCollister185c8ae2016-05-26 08:55:16 -0500287 fdt_line="fdt = \"fdt@${3}\";"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600288 fi
289
290 if [ -n "${4}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800291 conf_desc="${conf_desc}${sep}ramdisk"
292 sep=", "
George McCollister185c8ae2016-05-26 08:55:16 -0500293 ramdisk_line="ramdisk = \"ramdisk@${4}\";"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500294 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600295
296 if [ -n "${5}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800297 conf_desc="${conf_desc}${sep}setup"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600298 setup_line="setup = \"setup@${5}\";"
299 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500300
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500301 if [ "${6}" = "1" ]; then
302 default_line="default = \"conf@${3}\";"
303 fi
304
George McCollister185c8ae2016-05-26 08:55:16 -0500305 cat << EOF >> ${1}
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500306 ${default_line}
307 conf@${3} {
308 description = "${6} ${conf_desc}";
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500309 ${kernel_line}
310 ${fdt_line}
George McCollister185c8ae2016-05-26 08:55:16 -0500311 ${ramdisk_line}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600312 ${setup_line}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500313 hash@1 {
314 algo = "${conf_csum}";
315 };
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600316EOF
317
318 if [ ! -z "${conf_sign_keyname}" ] ; then
319
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800320 sign_line="sign-images = "
321 sep=""
322
323 if [ -n "${2}" ]; then
324 sign_line="${sign_line}${sep}\"kernel\""
325 sep=", "
326 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600327
328 if [ -n "${3}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800329 sign_line="${sign_line}${sep}\"fdt\""
330 sep=", "
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600331 fi
332
333 if [ -n "${4}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800334 sign_line="${sign_line}${sep}\"ramdisk\""
335 sep=", "
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600336 fi
337
338 if [ -n "${5}" ]; then
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800339 sign_line="${sign_line}${sep}\"setup\""
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600340 fi
341
342 sign_line="${sign_line};"
343
344 cat << EOF >> ${1}
345 signature@1 {
346 algo = "${conf_csum},rsa2048";
347 key-name-hint = "${conf_sign_keyname}";
348 ${sign_line}
349 };
350EOF
351 fi
352
353 cat << EOF >> ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500354 };
355EOF
356}
357
George McCollister185c8ae2016-05-26 08:55:16 -0500358#
359# Assemble fitImage
360#
361# $1 ... .its filename
362# $2 ... fitImage name
363# $3 ... include ramdisk
364fitimage_assemble() {
365 kernelcount=1
366 dtbcount=""
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500367 DTBS=""
George McCollister185c8ae2016-05-26 08:55:16 -0500368 ramdiskcount=${3}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600369 setupcount=""
George McCollister185c8ae2016-05-26 08:55:16 -0500370 rm -f ${1} arch/${ARCH}/boot/${2}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500371
George McCollister185c8ae2016-05-26 08:55:16 -0500372 fitimage_emit_fit_header ${1}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500373
George McCollister185c8ae2016-05-26 08:55:16 -0500374 #
375 # Step 1: Prepare a kernel image section.
376 #
377 fitimage_emit_section_maint ${1} imagestart
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500378
George McCollister185c8ae2016-05-26 08:55:16 -0500379 uboot_prep_kimage
380 fitimage_emit_section_kernel ${1} "${kernelcount}" linux.bin "${linux_comp}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500381
George McCollister185c8ae2016-05-26 08:55:16 -0500382 #
383 # Step 2: Prepare a DTB image section
384 #
Brad Bishop19323692019-04-05 15:28:33 -0400385
386 if [ -z "${EXTERNAL_KERNEL_DEVICETREE}" ] && [ -n "${KERNEL_DEVICETREE}" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500387 dtbcount=1
George McCollister185c8ae2016-05-26 08:55:16 -0500388 for DTB in ${KERNEL_DEVICETREE}; do
389 if echo ${DTB} | grep -q '/dts/'; then
390 bbwarn "${DTB} contains the full path to the the dts file, but only the dtb name should be used."
391 DTB=`basename ${DTB} | sed 's,\.dts$,.dtb,g'`
392 fi
393 DTB_PATH="arch/${ARCH}/boot/dts/${DTB}"
394 if [ ! -e "${DTB_PATH}" ]; then
395 DTB_PATH="arch/${ARCH}/boot/${DTB}"
396 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500397
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500398 DTB=$(echo "${DTB}" | tr '/' '_')
399 DTBS="${DTBS} ${DTB}"
400 fitimage_emit_section_dtb ${1} ${DTB} ${DTB_PATH}
George McCollister185c8ae2016-05-26 08:55:16 -0500401 done
402 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500403
Brad Bishop19323692019-04-05 15:28:33 -0400404 if [ -n "${EXTERNAL_KERNEL_DEVICETREE}" ]; then
405 dtbcount=1
406 for DTBFILE in ${EXTERNAL_KERNEL_DEVICETREE}/*.dtb; do
407 DTB=`basename ${DTBFILE}`
408 DTB=$(echo "${DTB}" | tr '/' '_')
409 DTBS="${DTBS} ${DTB}"
410 fitimage_emit_section_dtb ${1} ${DTB} ${DTBFILE}
411 done
412 fi
413
George McCollister185c8ae2016-05-26 08:55:16 -0500414 #
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600415 # Step 3: Prepare a setup section. (For x86)
416 #
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500417 if [ -e arch/${ARCH}/boot/setup.bin ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600418 setupcount=1
419 fitimage_emit_section_setup ${1} "${setupcount}" arch/${ARCH}/boot/setup.bin
420 fi
421
422 #
423 # Step 4: Prepare a ramdisk section.
George McCollister185c8ae2016-05-26 08:55:16 -0500424 #
425 if [ "x${ramdiskcount}" = "x1" ] ; then
Rick Altherrbc1b8802017-01-20 11:28:53 -0800426 # Find and use the first initramfs image archive type we find
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800427 for img in cpio.lz4 cpio.lzo cpio.lzma cpio.xz cpio.gz ext2.gz cpio; do
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500428 initramfs_path="${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE_NAME}.${img}"
Rick Altherrbc1b8802017-01-20 11:28:53 -0800429 echo "Using $initramfs_path"
430 if [ -e "${initramfs_path}" ]; then
431 fitimage_emit_section_ramdisk ${1} "${ramdiskcount}" "${initramfs_path}"
432 break
433 fi
434 done
George McCollister185c8ae2016-05-26 08:55:16 -0500435 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500436
George McCollister185c8ae2016-05-26 08:55:16 -0500437 fitimage_emit_section_maint ${1} sectend
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500438
George McCollister185c8ae2016-05-26 08:55:16 -0500439 # Force the first Kernel and DTB in the default config
440 kernelcount=1
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500441 if [ -n "${dtbcount}" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600442 dtbcount=1
443 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500444
George McCollister185c8ae2016-05-26 08:55:16 -0500445 #
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600446 # Step 5: Prepare a configurations section
George McCollister185c8ae2016-05-26 08:55:16 -0500447 #
448 fitimage_emit_section_maint ${1} confstart
449
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500450 if [ -n "${DTBS}" ]; then
451 i=1
452 for DTB in ${DTBS}; do
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800453 dtb_ext=${DTB##*.}
454 if [ "${dtb_ext}" = "dtbo" ]; then
455 fitimage_emit_section_config ${1} "" "${DTB}" "" "" "`expr ${i} = ${dtbcount}`"
456 else
457 fitimage_emit_section_config ${1} "${kernelcount}" "${DTB}" "${ramdiskcount}" "${setupcount}" "`expr ${i} = ${dtbcount}`"
458 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500459 i=`expr ${i} + 1`
460 done
461 fi
George McCollister185c8ae2016-05-26 08:55:16 -0500462
463 fitimage_emit_section_maint ${1} sectend
464
465 fitimage_emit_section_maint ${1} fitend
466
467 #
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600468 # Step 6: Assemble the image
George McCollister185c8ae2016-05-26 08:55:16 -0500469 #
470 uboot-mkimage \
471 ${@'-D "${UBOOT_MKIMAGE_DTCOPTS}"' if len('${UBOOT_MKIMAGE_DTCOPTS}') else ''} \
472 -f ${1} \
473 arch/${ARCH}/boot/${2}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600474
475 #
476 # Step 7: Sign the image and add public key to U-Boot dtb
477 #
478 if [ "x${UBOOT_SIGN_ENABLE}" = "x1" ] ; then
Brad Bishop19323692019-04-05 15:28:33 -0400479 add_key_to_u_boot=""
480 if [ -n "${UBOOT_DTB_BINARY}" ]; then
481 # The u-boot.dtb is a symlink to UBOOT_DTB_IMAGE, so we need copy
482 # both of them, and don't dereference the symlink.
483 cp -P ${STAGING_DATADIR}/u-boot*.dtb ${B}
484 add_key_to_u_boot="-K ${B}/${UBOOT_DTB_BINARY}"
485 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600486 uboot-mkimage \
487 ${@'-D "${UBOOT_MKIMAGE_DTCOPTS}"' if len('${UBOOT_MKIMAGE_DTCOPTS}') else ''} \
488 -F -k "${UBOOT_SIGN_KEYDIR}" \
Brad Bishop19323692019-04-05 15:28:33 -0400489 $add_key_to_u_boot \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600490 -r arch/${ARCH}/boot/${2}
491 fi
George McCollister185c8ae2016-05-26 08:55:16 -0500492}
493
494do_assemble_fitimage() {
495 if echo ${KERNEL_IMAGETYPES} | grep -wq "fitImage"; then
496 cd ${B}
497 fitimage_assemble fit-image.its fitImage
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500498 fi
499}
500
501addtask assemble_fitimage before do_install after do_compile
502
George McCollister185c8ae2016-05-26 08:55:16 -0500503do_assemble_fitimage_initramfs() {
504 if echo ${KERNEL_IMAGETYPES} | grep -wq "fitImage" && \
505 test -n "${INITRAMFS_IMAGE}" ; then
506 cd ${B}
507 fitimage_assemble fit-image-${INITRAMFS_IMAGE}.its fitImage-${INITRAMFS_IMAGE} 1
508 fi
509}
510
Brad Bishop19323692019-04-05 15:28:33 -0400511addtask assemble_fitimage_initramfs before do_deploy after do_bundle_initramfs
George McCollister185c8ae2016-05-26 08:55:16 -0500512
513
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500514kernel_do_deploy[vardepsexclude] = "DATETIME"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500515kernel_do_deploy_append() {
516 # Update deploy directory
He Zhefe76b1e2016-05-25 04:47:16 -0400517 if echo ${KERNEL_IMAGETYPES} | grep -wq "fitImage"; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500518 echo "Copying fit-image.its source file..."
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800519 install -m 0644 ${B}/fit-image.its ${DEPLOYDIR}/fitImage-its-${KERNEL_FIT_NAME}.its
520 ln -snf fitImage-its-${KERNEL_FIT_NAME}.its ${DEPLOYDIR}/fitImage-its-${KERNEL_FIT_LINK_NAME}
521
522 echo "Copying linux.bin file..."
523 install -m 0644 ${B}/linux.bin ${DEPLOYDIR}/fitImage-linux.bin-${KERNEL_FIT_NAME}.bin
524 ln -snf fitImage-linux.bin-${KERNEL_FIT_NAME}.bin ${DEPLOYDIR}/fitImage-linux.bin-${KERNEL_FIT_LINK_NAME}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500525
George McCollister185c8ae2016-05-26 08:55:16 -0500526 if [ -n "${INITRAMFS_IMAGE}" ]; then
527 echo "Copying fit-image-${INITRAMFS_IMAGE}.its source file..."
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800528 install -m 0644 ${B}/fit-image-${INITRAMFS_IMAGE}.its ${DEPLOYDIR}/fitImage-its-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_NAME}.its
529 ln -snf fitImage-its-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_NAME}.its ${DEPLOYDIR}/fitImage-its-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_LINK_NAME}
George McCollister185c8ae2016-05-26 08:55:16 -0500530
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800531 echo "Copying fitImage-${INITRAMFS_IMAGE} file..."
532 install -m 0644 ${B}/arch/${ARCH}/boot/fitImage-${INITRAMFS_IMAGE} ${DEPLOYDIR}/fitImage-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_NAME}.bin
533 ln -snf fitImage-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_NAME}.bin ${DEPLOYDIR}/fitImage-${INITRAMFS_IMAGE_NAME}-${KERNEL_FIT_LINK_NAME}
George McCollister185c8ae2016-05-26 08:55:16 -0500534 fi
Brad Bishop19323692019-04-05 15:28:33 -0400535 if [ "${UBOOT_SIGN_ENABLE}" = "1" -a -n "${UBOOT_DTB_BINARY}" ] ; then
536 # UBOOT_DTB_IMAGE is a realfile, but we can't use
537 # ${UBOOT_DTB_IMAGE} since it contains ${PV} which is aimed
538 # for u-boot, but we are in kernel env now.
539 install -m 0644 ${B}/u-boot-${MACHINE}*.dtb ${DEPLOYDIR}/
540 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500541 fi
542}