blob: d9ec023bfdae9a1a5d595d5999789ab3dff39dc4 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Systemd system configuration"
2DESCRIPTION = "Systemd may require slightly different configuration for \
3different machines. For example, qemu machines require a longer \
4DefaultTimeoutStartSec setting."
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8SRC_URI = "\
9 file://journald.conf \
10 file://logind.conf \
11 file://system.conf \
12 file://system.conf-qemuall \
Brad Bishop15ae2502019-06-18 21:44:24 -040013 file://wired.network \
Brad Bishopc342db32019-05-15 21:57:59 -040014"
15
16do_install() {
17 install -D -m0644 ${WORKDIR}/journald.conf ${D}${systemd_unitdir}/journald.conf.d/00-${PN}.conf
18 install -D -m0644 ${WORKDIR}/logind.conf ${D}${systemd_unitdir}/logind.conf.d/00-${PN}.conf
19 install -D -m0644 ${WORKDIR}/system.conf ${D}${systemd_unitdir}/system.conf.d/00-${PN}.conf
Brad Bishop15ae2502019-06-18 21:44:24 -040020 install -D -m0644 ${WORKDIR}/wired.network ${D}${systemd_unitdir}/network/80-wired.network
Brad Bishopc342db32019-05-15 21:57:59 -040021}
22
23# Based on change from YP bug 8141, OE commit 5196d7bacaef1076c361adaa2867be31759c1b52
24do_install_append_qemuall() {
25 install -D -m0644 ${WORKDIR}/system.conf-qemuall ${D}${systemd_unitdir}/system.conf.d/01-${PN}.conf
Brad Bishop15ae2502019-06-18 21:44:24 -040026
27 # Do not install wired.network for qemu bsps
28 rm -rf ${D}${systemd_unitdir}/network
Brad Bishopc342db32019-05-15 21:57:59 -040029}
30
31PACKAGE_ARCH = "${MACHINE_ARCH}"
32
33FILES_${PN} = "\
34 ${systemd_unitdir}/journald.conf.d/ \
35 ${systemd_unitdir}/logind.conf.d/ \
36 ${systemd_unitdir}/system.conf.d/ \
Brad Bishop15ae2502019-06-18 21:44:24 -040037 ${systemd_unitdir}/network/ \
Brad Bishopc342db32019-05-15 21:57:59 -040038"