blob: 9d8f2e7870eb4bbb724b6b2438e5d3e01d156944 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
Brad Bishop15ae2502019-06-18 21:44:24 -04007SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
8 file://add-disable-werror-option-to-configure.patch \
9 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010SRC_URI[md5sum] = "04969ad59cc37bddd83741a08b98f350"
11SRC_URI[sha256sum] = "b87e608d4d3f7bfdd36ef78d56d53c74e66ab278d318b71e6002a369d36f4873"
12
13UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar"
14# json-c releases page is fetching the list of releases in some weird XML format
15# from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/
16#UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html"
17RECIPE_UPSTREAM_VERSION = "0.13.1"
18RECIPE_UPSTREAM_DATE = "Mar 04, 2018"
19CHECK_DATE = "May 02, 2018"
20
21RPROVIDES_${PN} = "libjson"
22
23inherit autotools
24
Brad Bishop15ae2502019-06-18 21:44:24 -040025EXTRA_OECONF = "--disable-werror \
26 --enable-rdrand \
27 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028
29do_configure_prepend() {
30 # Clean up autoconf cruft that should not be in the tarball
31 rm -f ${S}/config.status
32}
33
34BBCLASSEXTEND = "native nativesdk"