blob: baf32f4724e2f681148ef74e1765cf299e04f804 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
6
7DEPENDS += "python3 python3-setuptools-native"
8
Brad Bishop15ae2502019-06-18 21:44:24 -04009SRC_URI[md5sum] = "4fb98a060f21c731d6743b90a714fc73"
10SRC_URI[sha256sum] = "44d3d7d3d30a1eb65c7e5ff1173cdf8f7467850605ac7cc3707b6064bddd0958"
Brad Bishopc342db32019-05-15 21:57:59 -040011
12inherit pypi distutils3
13
14do_install_append() {
15 # Install as pip3 and leave pip2 as default
16 rm ${D}/${bindir}/pip
17}
18
19RDEPENDS_${PN} = "\
20 python3-compile \
21 python3-io \
22 python3-html \
23 python3-json \
24 python3-netserver \
25 python3-setuptools \
26 python3-unixadmin \
27 python3-xmlrpc \
28"
29
30BBCLASSEXTEND = "native nativesdk"