blob: 6d62ce6cc551131a907edeaa1550d188fe4f43d1 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A parallel implementation of gzip"
2DESCRIPTION = "pigz, which stands for parallel implementation of gzip, is a \
3fully functional replacement for gzip that exploits multiple processors and \
4multiple cores to the hilt when compressing data. pigz was written by Mark \
5Adler, and uses the zlib and pthread libraries."
6HOMEPAGE = "http://zlib.net/pigz/"
7SECTION = "console/utils"
8LICENSE = "Zlib & Apache-2.0"
9LIC_FILES_CHKSUM = "file://pigz.c;md5=9ae6dee8ceba9610596ed0ada493d142;beginline=7;endline=21"
10
11SRC_URI = "http://zlib.net/${BPN}/fossils/${BP}.tar.gz"
12SRC_URI[md5sum] = "def2f6e19d9d8231445adc1349d346df"
13SRC_URI[sha256sum] = "a4f816222a7b4269bd232680590b579ccc72591f1bb5adafcd7208ca77e14f73"
Brad Bishop15ae2502019-06-18 21:44:24 -040014PROVIDES_class-native += "gzip-native"
15
Brad Bishop316dfdd2018-06-25 12:45:53 -040016# Point this at the homepage in case /fossils/ isn't updated
17UPSTREAM_CHECK_URI = "http://zlib.net/${BPN}/"
18UPSTREAM_CHECK_REGEX = "pigz-(?P<pver>.*)\.tar"
19
20DEPENDS = "zlib"
21
22EXTRA_OEMAKE = "-e MAKEFLAGS="
23
Brad Bishop15ae2502019-06-18 21:44:24 -040024inherit update-alternatives
25
Brad Bishop316dfdd2018-06-25 12:45:53 -040026do_install() {
27 # Install files into /bin (FHS), which is typical place for gzip
28 install -d ${D}${base_bindir}
29 install ${B}/pigz ${D}${base_bindir}/pigz
30 ln -nsf pigz ${D}${base_bindir}/unpigz
31 ln -nsf pigz ${D}${base_bindir}/pigzcat
32}
33
Brad Bishop15ae2502019-06-18 21:44:24 -040034do_install_append_class-native() {
35 install -d ${D}${bindir}
36 install ${B}/pigz ${D}${bindir}/gzip
37 ln -nsf gzip ${D}${bindir}/gunzip
38 ln -nsf gzip ${D}${bindir}/zcat
39}
40
41ALTERNATIVE_PRIORITY = "80"
42ALTERNATIVE_${PN} = "gunzip gzip zcat"
43ALTERNATIVE_${PN}_class-nativesdk = ""
44ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip"
45ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip"
46ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat"
47ALTERNATIVE_TARGET = "${base_bindir}/pigz"
48
Brad Bishop316dfdd2018-06-25 12:45:53 -040049BBCLASSEXTEND = "native nativesdk"